z_components 0.3.2
z_components: ^0.3.2 copied to clipboard

Z_Components is a package that contains a set of standardized components to facilitate, optimize, and accelerate the development of Zellar company's Android / IOS applications.

4
likes
50 / 110
pub points
61 %
popularity

We analyzed this package on Mar 27, 2021, and awarded it 50 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 67 out of 1046 API elements (6.4 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:z_components/api/quadro-pessoal-service.dart that declares support for platforms: Android, iOS
Pass static analysis
0 / 30

0/30 points: code has no errors, warnings, lints, or formatting issues

Found 85 issues. Showing the first 2:

ERROR: The named parameter 'actionsForegroundColor' isn't defined.

lib/components/z_navigationbar.dart:71:7

   ╷
71 │       actionsForegroundColor: this.actionsForegroundColor,
   │       ^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/components/z_navigationbar.dart

INFO: Name non-constant identifiers using lowerCamelCase.

lib/api/quadro-pessoal-service.dart:12:7

   ╷
12 │   var _URL = "${ApiSettings.ENDPOINT}/quadro-pessoal";
   │       ^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/api/quadro-pessoal-service.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
configurable_expansion_tile^1.0.01.0.01.0.0
cpf_cnpj_validator^1.0.51.0.51.0.5
email_validator^1.0.01.0.62.0.1
flare_flutter^1.5.11.8.32.0.6
flutterflutter0.0.00.0.0
flutter_circular_chart^0.1.00.1.00.1.0
flutter_localizationsflutter0.0.00.0.0
http^0.12.0+10.12.20.13.1
mask_shifter^0.1.00.1.00.1.0
pin_code_text_field^1.3.61.8.01.8.0
provider^2.0.12.0.1+15.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.5.02.5.0
boolean_selector-2.1.02.1.0
characters-1.1.01.1.0
charcode-1.2.01.2.0
clock-1.1.01.1.0
collection-1.15.01.15.0
fake_async-1.2.01.2.0
flare_dart-2.3.42.3.4
http_parser-3.1.44.0.0
intl-0.17.00.17.0
matcher-0.12.100.12.10
meta-1.3.01.3.0
path-1.8.01.8.0
pedantic-1.11.01.11.0
sky_engine-0.0.990.0.99
source_span-1.8.01.8.1
stack_trace-1.10.01.10.0
stream_channel-2.1.02.1.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
test_api-0.2.190.3.0
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 4 issues. Showing the first 2:

The constraint `^1.0.0` on email_validator does not support the stable version `2.0.1`, that was published 13 days ago.

When email_validator is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions email_validator to update the constraint.

The constraint `^1.5.1` on flare_flutter does not support the stable version `2.0.1`.

Try running dart pub upgrade --major-versions flare_flutter to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.4, Flutter 2.0.3, Dart 2.12.2.

4
likes
50
pub points
61%
popularity

Z_Components is a package that contains a set of standardized components to facilitate, optimize, and accelerate the development of Zellar company's Android / IOS applications.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploaders

victortmarques@gmail.com
tiezzi76@gmail.com
giu.oortiz@gmail.com

License

LICENSE

Dependencies

configurable_expansion_tile, cpf_cnpj_validator, email_validator, flare_flutter, flutter, flutter_circular_chart, flutter_localizations, http, mask_shifter, pin_code_text_field, provider

More

Packages that depend on z_components