z85 0.1.0

  • README.md
  • Installing
  • Versions
  • 40

z85 #

A z85 encoder and decoder. Implements the full dart:convert Codec API.

Usage #

z85 can be used just like all the dart:convert codecs (e.g. base64):

import 'package:z85/z85.dart';

void main() {
  final testBytes = [0x86, 0x4F, 0xD2, 0x6F, 0xB5, 0x59, 0xF7, 0x5B];
  final testString = 'HelloWorld';

  assert(z85.encode(testBytes) == testString);
  assert(z85.decode(testString) == testBytes);
}

Chunked conversions are also supported, again by following the same API. See the API docs for more information.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  z85: ^0.1.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:z85/z85.dart';
  
Version Uploaded Documentation Archive
0.1.0 Jan 11, 2019 Go to the documentation of z85 0.1.0 Download z85 0.1.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
50
Overall:
Weighted score of the above. [more]
40
Learn more about scoring.

We analyzed this package on May 22, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.3.1
  • pana: 0.12.16

Platforms

Detected platforms: Flutter, web, other

No platform restriction found in primary library package:z85/z85.dart.

Maintenance issues and suggestions

Provide a file named CHANGELOG.md. (-20 points)

Changelog entries help developers follow the progress of your package. See the example generated by stagehand.

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and z85.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
Dev dependencies
test any