A new flutter plugin project.
export http_proxy=http://127.0.0.1:1087;export https_proxy=http://127.0.0.1:1087 //取消命令 unset http_proxy;unset https_proxy //1.设置SS为全局模式 //2.查看ip归属地是否在国外 curl cip.cc //3.查看google是否能访问 curl www.google.com //4.sudo运行，-v 查看详细信息 flutter packages pub publish -v //先执行下，会报错，报错以后再执行下一句，不知道为什么一定要这样才能提交 sudo flutter packages pub publish -v
Demonstrates how to use the ykd_audio_recorder plugin.
This project is a starting point for a Flutter application.
A few resources to get you started if this is your first Flutter project:
For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.
Add this to your package's pubspec.yaml file:
dependencies: ykd_audio_recorder: ^1.2.0
You can install packages from the command line:
$ flutter pub get
Alternatively, your editor might support
flutter pub get.
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
We analyzed this package on Jul 17, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:
Detected platforms: Flutter
References Flutter, and has no conflicting libraries.
Document public APIs. (-1 points)
29 out of 29 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.
lib/ykd_audio_recorder.dart. (-1 points)
lib/ykd_audio_recorder.dart reported 2 hints:
line 6 col 8: Unused import: 'package:path/path.dart'.
line 23 col 35: This function has a return type of 'Future', but doesn't end with a return statement.
Homepage URL doesn't exist. (-20 points)
At the time of the analysis the
https://www.youkeda.com was unreachable.
Support latest dependencies. (-10 points)
The version constraint in
pubspec.yaml does not support the latest published versions for 1 dependency (
The package description is too short. (-20 points)
Add more detail to the
description field of
pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.
|Dart SDK||>=2.1.0 <3.0.0|