yin_ui 0.0.22

  • Readme
  • Changelog
  • Installing
  • 44

yin_ui #

According to the Weui(Weui: 0.0.5) project, I learned and adjusted part of the code to meet my project requirements Initially, we will modify the Weui project, and later we will add functions that are not available

根据Weui(Weui: 0.0.5) 项目学习并调整部分代码,满足自己项目需求 初期是在Weui项目上修改,后期会新增没有的功能

Getting Started #

码云:https://gitee.com/xinliuyu/flutter_ui.git(最新) github:https://github.com/yx544806988/yin_ui.git

  • animation
  • badge
  • button
  • collapse
  • dialog
  • icon
  • loadmore
  • radio
  • theme
  • toast

[0.0.1] - TODO: Add release date.

  • TODO: Describe initial release.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  yin_ui: ^0.0.22

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:yin_ui/actionsheet/android_widget.dart';
import 'package:yin_ui/actionsheet/index.dart';
import 'package:yin_ui/actionsheet/ios_widget.dart';
import 'package:yin_ui/actionsheet/utils.dart';
import 'package:yin_ui/animation/fade_in.dart';
import 'package:yin_ui/animation/rotating.dart';
import 'package:yin_ui/animation/scale.dart';
import 'package:yin_ui/badge/index.dart';
import 'package:yin_ui/button/index.dart';
import 'package:yin_ui/cell/index.dart';
import 'package:yin_ui/checkbox/index.dart';
import 'package:yin_ui/collapse/index.dart';
import 'package:yin_ui/dialog/android_widget.dart';
import 'package:yin_ui/dialog/custom_widget.dart';
import 'package:yin_ui/dialog/index.dart';
import 'package:yin_ui/dialog/ios_widget.dart';
import 'package:yin_ui/dialog/layout_hoc.dart';
import 'package:yin_ui/dialog/service_widget.dart';
import 'package:yin_ui/drawer/drawer.dart';
import 'package:yin_ui/drawer/index.dart';
import 'package:yin_ui/form/index.dart';
import 'package:yin_ui/icon/index.dart';
import 'package:yin_ui/image_preview/index.dart';
import 'package:yin_ui/image_preview/preview_widget.dart';
import 'package:yin_ui/input/index.dart';
import 'package:yin_ui/load_empty_error/index.dart';
import 'package:yin_ui/loadmore/index.dart';
import 'package:yin_ui/notify/index.dart';
import 'package:yin_ui/notify/notify.dart';
import 'package:yin_ui/number/index.dart';
import 'package:yin_ui/picker_view/index.dart';
import 'package:yin_ui/radio/index.dart';
import 'package:yin_ui/swipe/index.dart';
import 'package:yin_ui/theme/index.dart';
import 'package:yin_ui/tip/WeTipWidget.dart';
import 'package:yin_ui/tip/index.dart';
import 'package:yin_ui/toast/index.dart';
import 'package:yin_ui/toast/info.dart';
import 'package:yin_ui/toast/toast.dart';
import 'package:yin_ui/ui.dart';
import 'package:yin_ui/utils.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
44
Learn more about scoring.

We analyzed this package on Dec 9, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.6.1
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.6

Health suggestions

Fix lib/cell/index.dart. (-0.50 points)

Analysis of lib/cell/index.dart reported 1 hint:

line 50 col 7: This class (or a class which this class inherits from) is marked as '@immutable', but one or more of its instance fields are not final: WeCell.label, WeCell.content

Fix lib/input/index.dart. (-0.50 points)

Analysis of lib/input/index.dart reported 1 hint:

line 6 col 7: This class (or a class which this class inherits from) is marked as '@immutable', but one or more of its instance fields are not final: WeInput.label, WeInput.clearable

Fix lib/tip/WeTipWidget.dart. (-0.50 points)

Analysis of lib/tip/WeTipWidget.dart reported 1 hint:

line 11 col 7: This class (or a class which this class inherits from) is marked as '@immutable', but one or more of its instance fields are not final: WeTipWidget.offset, WeTipWidget.top, WeTipWidget.left, WeTipWidget.triangleOffset, WeTipWidget.triangleTop, WeTipWidget.triangleLeft, WeTipWidget.angle

Fix additional 17 files with analysis or formatting issues.

Additional issues in the following files:

  • lib/actionsheet/android_widget.dart (Run flutter format to format lib/actionsheet/android_widget.dart.)
  • lib/actionsheet/ios_widget.dart (Run flutter format to format lib/actionsheet/ios_widget.dart.)
  • lib/actionsheet/utils.dart (Run flutter format to format lib/actionsheet/utils.dart.)
  • lib/animation/rotating.dart (Run flutter format to format lib/animation/rotating.dart.)
  • lib/collapse/index.dart (Run flutter format to format lib/collapse/index.dart.)
  • lib/dialog/android_widget.dart (Run flutter format to format lib/dialog/android_widget.dart.)
  • lib/dialog/index.dart (Run flutter format to format lib/dialog/index.dart.)
  • lib/dialog/ios_widget.dart (Run flutter format to format lib/dialog/ios_widget.dart.)
  • lib/dialog/service_widget.dart (Run flutter format to format lib/dialog/service_widget.dart.)
  • lib/drawer/drawer.dart (Run flutter format to format lib/drawer/drawer.dart.)
  • lib/form/index.dart (Run flutter format to format lib/form/index.dart.)
  • lib/icon/index.dart (Run flutter format to format lib/icon/index.dart.)
  • lib/loadmore/index.dart (Run flutter format to format lib/loadmore/index.dart.)
  • lib/number/index.dart (Run flutter format to format lib/number/index.dart.)
  • lib/picker_view/index.dart (Run flutter format to format lib/picker_view/index.dart.)
  • lib/swipe/index.dart (Run flutter format to format lib/swipe/index.dart.)
  • lib/toast/index.dart (Run flutter format to format lib/toast/index.dart.)

Maintenance suggestions

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and yin_ui.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

The description is too long. (-10 points)

Search engines display only the first part of the description. Try to keep the value of the description field in your package's pubspec.yaml file between 60 and 180 characters.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.7 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test