wizard_dub_ski 0.0.1 icon indicating copy to clipboard operation
wizard_dub_ski: ^0.0.1 copied to clipboard

Library to create CLI wizards by Zhenya Dubskiy <e.dubskiy@gmail.com>

0
likes
90/ 130
pub points
0%
popularity

We analyzed this package 5 days ago, and awarded it 90 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
20 / 20icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
10 / 20icon to trigger folding of the section

10/10 points: Package has an example

0/10 points: 20% or more of the public API has dartdoc comments

  • 0 out of 11 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:wizard_dub_ski/wizard_dub_ski.dart that imports:
  • package:wizard_dub_ski/src/prompter.dart that imports:
  • package:wizard_dub_ski/src/terminal.dart that imports:
  • dart:io
icon indicating section status
Pass static analysis
30 / 30icon to trigger folding of the section

30/30 points: code has no errors, warnings, lints, or formatting issues

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

  • Could not run dart pub outdated: dart pub get failed:
OUT:
Resolving dependencies...
ERR:
pubspec.yaml has no lower-bound SDK constraint.
You should edit pubspec.yaml to contain an SDK constraint:

environment:
  sdk: '>=2.10.0 <3.0.0'

See https://dart.dev/go/sdk-constraint

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `<3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.12, Dart 2.17.3.

0
likes
90
pub points
0%
popularity

Publisher

unverified uploader

Library to create CLI wizards by Zhenya Dubskiy <e.dubskiy@gmail.com>

Homepage

Documentation

API reference

License

Icon for licenses.unknown (LICENSE)

More

Packages that depend on wizard_dub_ski