wifi_ip 0.0.1

  • Readme
  • Changelog
  • Example
  • Installing
  • 69

Build Status

get_wifi_info #

A flutter plugin to get Wifi IP info.

Getting Started #

Pubspec #

  1. Add to pubspec
  get_wifi_info:
    git:
      url: https://github.com/luanvotrongdev/get_wifi_info.git
  1. run pub get

Android #

  1. Add <uses-permission android:name="android.permission.ACCESS_WIFI_STATE" /> to AndroidManifest
  2. Call API
WifiInfo info;
try {
  info = await GetWifiInfo.getWifiInfo;
} on PlatformException {
  print('Failed to get broadcast IP.');
}

iOS #

  1. Call API
WifiInfo info;
try {
  info = await GetWifiInfo.getWifiInfo;
} on PlatformException {
  print('Failed to get broadcast IP.');
}

Demo #

iOSAndroid

0.0.1 #

  • Initial Release
  • No tests

example/lib/main.dart

import 'package:flutter/material.dart';
import 'dart:async';

import 'package:flutter/services.dart';
import 'package:wifi_ip/wifi_ip.dart';

void main() => runApp(MyApp());

class MyApp extends StatefulWidget {
  @override
  _MyAppState createState() => _MyAppState();
}

class _MyAppState extends State<MyApp> {
  WifiIpInfo _result;

  @override
  void initState() {
    super.initState();
    initPlatformState();
  }

  // Platform messages are asynchronous, so we initialize in an async method.
  Future<void> initPlatformState() async {
    // Platform messages may fail, so we use a try/catch PlatformException.
    WifiIpInfo info;
    try {
      info = await WifiIp.getWifiIp;
    } on PlatformException {
      print('Failed to get broadcast IP.');
    }

    // If the widget was removed from the tree while the asynchronous platform
    // message was in flight, we want to discard the reply rather than calling
    // setState to update our non-existent appearance.
    if (!mounted) return;

    setState(() {
      _result = info;
    });
  }

  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      home: Scaffold(
        appBar: AppBar(
          title: const Text('Plugin example app'),
        ),
        body: Center(
          child: _result == null ?
          Text("Getting Wifi Info") :
          Column(
            mainAxisAlignment: MainAxisAlignment.center,
            children: <Widget>[
              Text("IP: ${_result.ip}"),
              Text("Netmask: ${_result.netmask}"),
              Text("Broadcast IP: ${_result.broadcastIP}"),
            ],
          ),
        ),
      ),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  wifi_ip: ^0.0.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:wifi_ip/wifi_ip.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
60
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
49
Overall:
Weighted score of the above. [more]
69
Learn more about scoring.

We analyzed this package on Apr 8, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.6
  • Flutter: 1.12.13+hotfix.8

Health issues and suggestions

Document public APIs. (-1 points)

9 out of 9 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Format lib/wifi_ip.dart.

Run flutter format to format lib/wifi_ip.dart.

Maintenance suggestions

Package is getting outdated. (-21.10 points)

The package was last published 63 weeks ago.

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8