w_qrcode 0.1.6

  • Readme
  • Changelog
  • Installing
  • 68

w_qrcode #

A Flutter plugin to scanning. Ready for Android

权限: #

<uses-permission android:name="android.permission.CAMERA" />

<uses-permission android:name="android.permission.WRITE_EXTERNAL_STORAGE"/>

<uses-permission android:name="android.permission.READ_EXTERNAL_STORAGE"/>

安装 #

Add this to your package's pubspec.yaml file:

dependencies:
 w_qrcode: ^0.1.6

使用方式 #

import 'package:w_qrcode/w_qrcode.dart' as scanner;

String barcode = await scanner.scan();

String photoScanResult = await scanner.scanPhoto();

许可 #

Distributed under the MIT license. See LICENSE for more information.

关于 #

Created by hookou.

0.1.0 - (2019/10/16) #

0.1.1 - (2019/10/16) #

0.1.2 - (2019/10/16) width: 320 #

0.1.3 - (2019/10/16) width: 350 #

0.1.4 - (2019/10/31) ios报错修复 #

0.1.5 - (2019/11/01) #

0.1.6 - (2019/11/01) #

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  w_qrcode: ^0.1.6

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:w_qrcode/w_qrcode.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
40
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
68
Learn more about scoring.

We analyzed this package on Apr 8, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.6
  • Flutter: 1.12.13+hotfix.8

Maintenance suggestions

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and w_qrcode.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
test ^1.5.1
test_coverage ^0.2.0