vscreen_client_core 0.1.7
vscreen_client_core: ^0.1.7

this is vscreen client core implementation

0
likes
25 / 110
pub points
0 %
popularity

We analyzed this package on Dec 1, 2020, and awarded it 25 pub points (of a possible 110):

Follow Dart file conventions
5 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

0/5 points: Provide a valid CHANGELOG.md

No `CHANGELOG.md` found.

Changelog entries help developers follow the progress of your package. See the example generated by stagehand.

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 23 out of 242 API elements (9.5 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:vscreen_client_core/vscreen_client_core.dart that imports:
  • package:vscreen_client_core/bloc/vscreen_state.dart that imports:
  • package:vscreen_client_core/model/vscreen_client_core.dart that imports:
  • package:grpc/grpc.dart that imports:
  • package:grpc/src/shared/streams.dart that imports:
  • package:http2/transport.dart that imports:
  • package:http2/src/hpack/hpack.dart that imports:
  • package:http2/src/hpack/huffman_table.dart that imports:
  • package:http2/src/hpack/huffman.dart that imports:
  • dart:io
Pass static analysis
0 / 30

0/30 points: code has no errors, warnings, lints, or formatting issues

Found 150 issues. Showing the first 2:

ERROR: Too many positional arguments: 3 expected, but 6 found.

lib/generated/vscreen.pb.dart:39:20

   ╷
39 │     ..e<StatusCode>(1, 'code', $pb.PbFieldType.OE, StatusCode.OK, StatusCode.valueOf, StatusCode.values)
   │                    ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/generated/vscreen.pb.dart

ERROR: Too many positional arguments: 3 expected, but 6 found.

lib/generated/vscreen.pb.dart:177:20

    ╷
177 │     ..e<Info_State>(4, 'state', $pb.PbFieldType.OE, Info_State.PLAYING, Info_State.valueOf, Info_State.values)
    │                    ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/generated/vscreen.pb.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
bloc^0.8.00.8.46.1.0
grpcany2.8.02.8.0
protobufany1.1.01.1.0
uuid2.0.0-rc12.0.0-rc12.2.2
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.4.22.4.2
charcode-1.1.31.1.3
collection-1.14.131.14.13
convert-2.1.12.1.1
crypto-2.1.52.1.5
fixnum-0.10.110.10.11
googleapis_auth-0.2.120.2.12
http-0.12.20.12.2
http2-1.0.11.0.1
http_parser-3.1.43.1.4
meta-1.2.41.2.4
path-1.7.01.7.0
pedantic-1.9.21.9.2
rxdart-0.24.10.24.1
source_span-1.7.01.7.0
string_scanner-1.0.51.0.5
term_glyph-1.1.01.1.0
typed_data-1.2.01.2.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.8.0` on bloc does not support the latest published version `6.1.0`

pubspec.yaml:11:9

   ╷
11 │   bloc: ^0.8.0
   │         ^^^^^^
   ╵
The constraint `2.0.0-rc1` on uuid does not support the latest published version `2.2.2`

pubspec.yaml:10:9

   ╷
10 │   uuid: 2.0.0-rc1
   │         ^^^^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

0
likes
25
pub points
0%
popularity

this is vscreen client core implementation

Homepage

Documentation

API reference

Uploader

lherman.cs@gmail.com

License

Apache 2.0 (LICENSE)

Dependencies

bloc, grpc, protobuf, uuid

More

Packages that depend on vscreen_client_core