vscreen_client_core 0.1.7

VScreen Client Core #

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  vscreen_client_core: ^0.1.7

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:vscreen_client_core/vscreen_client_core.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
42
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
3
Overall:
Weighted score of the above. [more]
13
Learn more about scoring.

We analyzed this package on Feb 18, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.5

Health issues and suggestions

Fix lib/generated/vscreen.pb.dart. (-51.12 points)

Analysis of lib/generated/vscreen.pb.dart failed with 2 errors, 28 hints, including:

line 39 col 20: Too many positional arguments: 3 expected, but 6 found.

line 177 col 20: Too many positional arguments: 3 expected, but 6 found.

line 17 col 37: Unnecessary new keyword.

line 24 col 20: Unnecessary new keyword.

line 27 col 28: Unnecessary new keyword.

Fix lib/generated/vscreen.pbgrpc.dart. (-23.71 points)

Analysis of lib/generated/vscreen.pbgrpc.dart reported 54 hints, including:

line 15 col 25: Unnecessary new keyword.

line 18 col 28: Unnecessary new keyword.

line 19 col 25: Unnecessary new keyword.

line 22 col 28: Unnecessary new keyword.

line 23 col 26: Unnecessary new keyword.

Fix lib/generated/vscreen.pbjson.dart. (-14.39 points)

Analysis of lib/generated/vscreen.pbjson.dart reported 31 hints, including:

line 7 col 25: Avoid const keyword.

line 9 col 8: Avoid const keyword.

line 10 col 5: Avoid const keyword.

line 14 col 20: Avoid const keyword.

line 18 col 21: Avoid const keyword.

Fix additional 3 files with analysis or formatting issues. (-9.30 points)

Additional issues in the following files:

  • lib/model/vscreen_client_core.dart (12 hints)
  • lib/generated/vscreen.pbenum.dart (6 hints)
  • lib/bloc/vscreen_bloc.dart (1 hint)

Maintenance issues and suggestions

Provide a file named CHANGELOG.md. (-20 points)

Changelog entries help developers follow the progress of your package. See the example generated by stagehand.

Support latest dependencies. (-20 points)

The version constraint in pubspec.yaml does not support the latest published versions for 2 dependencies (bloc, uuid).

Use constrained dependencies. (-20 points)

The pubspec.yaml contains 2 dependencies without version constraints. Specify version ranges for the following dependencies: grpc, protobuf.

The package description is too short. (-18 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and vscreen_client_core.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Package is getting outdated. (-8.77 points)

The package was last published 56 weeks ago.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.8.0 <3.0.0
bloc ^0.8.0 0.8.4 3.0.0
grpc any 2.1.3
protobuf any 1.0.1
uuid 2.0.0-rc1 2.0.0-rc1 2.0.4
Transitive dependencies
async 2.4.0
charcode 1.1.3
collection 1.14.12
convert 2.1.1
crypto 2.1.4
fixnum 0.10.11
googleapis_auth 0.2.11+1
http 0.12.0+4
http2 1.0.0
http_parser 3.1.3
meta 1.1.8
path 1.6.4
pedantic 1.9.0
rxdart 0.23.1
source_span 1.6.0
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6