vitor_myparser_nfce 1.0.0

MyParserNFce #

Biblioteca desenvolvida para realizar o download de NFc-e e utilizar no meu exemplo de Flutter.


  • Se você está procurando algum PATTERN. NÃO TEM!
  • Os testes foram feitos apenas na Sefaz do RS.
  • Não use.

1.0.0 #

  • Initial version, created by Stagehand

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  vitor_myparser_nfce: ^1.0.0

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:vitor_myparser_nfce/models/nfce.dart';
import 'package:vitor_myparser_nfce/models/nfce_comercio.dart';
import 'package:vitor_myparser_nfce/models/nfce_item.dart';
import 'package:vitor_myparser_nfce/my_parser_nfce.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Sep 16, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.0
  • pana: 0.12.21


Detected platforms: Flutter, other

Platform components identified in package: io.

Health issues and suggestions

Document public APIs. (-1 points)

64 out of 64 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Fix lib/my_parser_nfce.dart. (-0.50 points)

Analysis of lib/my_parser_nfce.dart reported 1 hint:

line 1 col 9: Name libraries using lowercase_with_underscores.

Maintenance issues and suggestions

Support latest dependencies. (-20 points)

The version constraint in pubspec.yaml does not support the latest published versions for 2 dependencies (html, intl).

Homepage URL isn't helpful. (-10 points)

Update the homepage field from pubspec.yaml: link to a website about the package or use the source repository URL.

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and vitor_myparser_nfce.dart. Packages with multiple examples should provide example/

For more information see the pub package layout conventions.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
html ^0.13.4+1 0.13.4+2 0.14.0+2
http ^0.12.0+1 0.12.0+2
intl ^0.15.7 0.15.8 0.16.0
Transitive dependencies
async 2.3.0
charcode 1.1.2
collection 1.14.12
csslib 0.15.0 0.16.1
http_parser 3.1.3
meta 1.1.7
path 1.6.4
source_span 1.5.5
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6
utf 0.9.0+5
Dev dependencies
pedantic ^1.0.0 1.8.0+1
test ^1.0.0