unix_crypt 1.0.1

  • Readme
  • Changelog
  • Example
  • Installing
  • 68

UnixCrypt #

This project was writed with pure dart code, it transform apache unix crypt of java.

Support #

It support salt crypt string. You can find the demo at the 'test' folder.

License #

See the LICENSE file.

[1.0.1] - 2019.12.18

  • Fix code format
  • Add example

[1.0.0] - 2019.12.18

  • Initial release of unix_crypt. Provides the basic API for writing and running tests on the VM.

example/README.md

See the demo at the 'test' folder.

import 'package:unix_crypt/unix_crypt.dart';

void main() {
  String salt = "salt-a123456";
  var result = UnixCrypt.cryptString("a123456",salt);
  print("result: $result");
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  unix_crypt: ^1.0.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:unix_crypt/unix_crypt.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
35
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
68
Learn more about scoring.

We analyzed this package on Jan 19, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.0
  • pana: 0.13.4
  • Flutter: 1.12.13+hotfix.5

Health suggestions

Format lib/unix_crypt.dart.

Run flutter format to format lib/unix_crypt.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test