umeng_analytics 0.0.6

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 53

umeng_analytics #

Flutter plugin for umeng:analytics

Usage #

Init #

import 'package:umeng_analytics/umeng_analytics.dart';

UMengAnalytics.init('AppKey', channel: 'default', policy: Policy.BATCH,
    encrypt: true, reportCrash: false);

0.0.6 #

  • update some document.

0.0.1 #

  • initial release. only init.

example/README.md

umeng_analytics_example #

Demonstrates how to use the umeng_analytics plugin.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  umeng_analytics: ^0.0.6

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:umeng_analytics/umeng_analytics.dart';
  
Version Uploaded Documentation Archive
0.0.6 Mar 4, 2019 Go to the documentation of umeng_analytics 0.0.6 Download umeng_analytics 0.0.6 archive
0.0.5 Mar 4, 2019 Go to the documentation of umeng_analytics 0.0.5 Download umeng_analytics 0.0.5 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
29
Health:
Code health derived from static analysis. [more]
97
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
46
Overall:
Weighted score of the above. [more]
53
Learn more about scoring.

We analyzed this package on Jun 26, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.3.2
  • pana: 0.12.18
  • Flutter: 1.5.4-hotfix.2

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health issues and suggestions

Document public APIs. (-1 points)

12 out of 12 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Fix lib/umeng_analytics.dart. (-1.99 points)

Analysis of lib/umeng_analytics.dart reported 4 hints:

line 6 col 20: Name non-constant identifiers using lowerCamelCase.

line 7 col 20: Name non-constant identifiers using lowerCamelCase.

line 8 col 20: Name non-constant identifiers using lowerCamelCase.

line 9 col 20: Name non-constant identifiers using lowerCamelCase.

Maintenance issues and suggestions

The description contains too many non-ASCII characters. (-20 points)

The site uses English as its primary language. The value of the description field in your package's pubspec.yaml field should primarily contain characters used in English.

Support latest dependencies. (-5 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency.

The package description is too short. (-19 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test