typed_data 1.1.5

Helper libraries for working with typed data lists. #

The typed_data package contains utility functions and classes that makes working with typed data lists easier.

Using #

The typed_data package can be imported as

import 'package:typed_data/typed_data.dart';

Typed buffers: Growable typed data lists #

Typed buffers are contains growable lists backed by typed arrays. These are similar to the growable lists returned by new List(), but stores typed data like a typed data list.

Features and bugs #

Please file feature requests and bugs at the issue tracker.

1.1.5 #

  • Undo unnessesary SDK version constraint tweak.

1.1.4 #

  • Expand the SDK version constraint to include <2.0.0-dev.infinity.

1.1.3 #

  • Fix all strong-mode warnings.

1.1.2 #

  • Fix a bug where TypedDataBuffer.insertAll could fail to insert some elements of an Iterable.

1.1.1 #

  • Optimize insertAll with an Iterable argument and no end-point.

1.1.0 #

  • Add start and end parameters to the addAll() and insertAll() methods for the typed data buffer classes. These allow efficient concatenation of slices of existing typed data.

  • Make addAll() for typed data buffer classes more efficient for lists, especially typed data lists.

1.0.0 #

  • ChangeLog starts here

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  typed_data: ^1.1.5

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:typed_data/typed_data.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
98
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
49
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.8.0 <2.0.0