system_setting 0.0.1

  • Readme
  • Changelog
  • Example
  • Installing
  • 79

system_setting #

pub package

A Flutter plugin for jumping to system settings. Currently support Android only. iOS support is coming soon.

Usage #

To use this plugin, add system_setting as a dependency in your pubspec.yaml file.

Example #

import 'package:flutter/material.dart';
import 'packages:system_setting/system_setting.dart';

void main() => runApp(Scaffold(
      body: Center(
        child: RaisedButton(
          onPressed: _jumpToSetting,
          child: Text('Show Flutter homepage'),
        ),
      ),
    ));

_jumpToSetting() {
  SystemSetting.goto(SettingTarget.WIFI);
}

0.0.1 #

  • TODO: Describe initial release.

example/lib/main.dart

import 'package:flutter/material.dart';
import 'dart:async';

import 'package:flutter/services.dart';
import 'package:system_setting/system_setting.dart';

void main() => runApp(Scaffold(
      body: Center(
        child: RaisedButton(
          onPressed: _jumpToSetting,
          child: Text('Show Flutter homepage'),
        ),
      ),
    ));

_jumpToSetting() {
  SystemSetting.goto(SettingTarget.WIFI);
}

class MyApp extends StatefulWidget {
  @override
  _MyAppState createState() => _MyAppState();
}

class _MyAppState extends State<MyApp> {
  String _platformVersion = 'Unknown';

  @override
  void initState() {
    super.initState();
    initPlatformState();
  }

  // Platform messages are asynchronous, so we initialize in an async method.
  Future<void> initPlatformState() async {
    String platformVersion;
    // Platform messages may fail, so we use a try/catch PlatformException.
    try {
      platformVersion = await SystemSetting.platformVersion;
    } on PlatformException {
      platformVersion = 'Failed to get platform version.';
    }

    // If the widget was removed from the tree while the asynchronous platform
    // message was in flight, we want to discard the reply rather than calling
    // setState to update our non-existent appearance.
    if (!mounted) return;

    setState(() {
      _platformVersion = platformVersion;
    });
  }

  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      home: Scaffold(
        appBar: AppBar(
          title: const Text('Plugin example app'),
        ),
        body: Column(
          children: <Widget>[
            Center(
              child: Text('Running on: $_platformVersion\n'),
            ),
            FlatButton(
                onPressed: () async {
                  await SystemSetting.goto(SettingTarget.WIFI);
                },
                child: Text("Goto setting"))
          ],
        ),
      ),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  system_setting: ^0.0.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:system_setting/system_setting.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
88
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
23
Overall:
Weighted score of the above. [more]
79
Learn more about scoring.

We analyzed this package on May 16, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.1
  • pana: 0.13.8-dev
  • Flutter: 1.17.0

Maintenance suggestions

Package is getting outdated. (-52.60 points)

The package was last published 79 weeks ago.

The package description is too short. (-14 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.12
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8