system_notifications 0.0.1-dev.3

  • Readme
  • Changelog
  • Example
  • Installing
  • new63

flutter_system_notifications #

Flutter plugin for system Notifications

0.0.1-dev.3 #

  • Added iOS System Notification with id, title and content

0.0.1-dev.2 #

  • Fixed Dart file format and plugin description

0.0.1-dev.1 #

  • Added Documentation for 0.0.1-dev

0.0.1-dev #

  • Added Android System Notification with id, title, content and dismissible

example/README.md

system_notifications_example #

Demonstrates how to use the system_notifications plugin.

iOS Setup #

If you want System notification while the app is in foreground add this:

In your AppDelegate.swift add this function:

override func userNotificationCenter(_ center: UNUserNotificationCenter,
    willPresent notification: UNNotification,
    withCompletionHandler completionHandler: @escaping (UNNotificationPresentationOptions) -> Void) {
    completionHandler([.alert, .badge, .sound])
}

And add in your application function:

UNUserNotificationCenter.current().delegate = self

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  system_notifications: ^0.0.1-dev.3

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:system_notifications/system_notifications.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
31
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
85
Overall:
Weighted score of the above. [more]
63
Learn more about scoring.

We analyzed this package on Feb 26, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.5
  • Flutter: 1.12.13+hotfix.8

Maintenance suggestions

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Package is pre-release. (-5 points)

Pre-release versions should be used with caution; their API can change in breaking ways.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test