stripe 2.0.2

  • Readme
  • Changelog
  • Installing
  • 78

Stripe Dart #

This implementation is based on the official Stripe Java and NodeJS API wrappers and written as a proper native dart library.

After rewriting (2.0.0) the library to prepare for SCA we only included the bare minimum needed for our project. We are open and encourage merge requests to increase coverage.

2.0.2 (2019-09-18) #

Fixes:

  • Make v0 part of the webhook signature optional

2.0.1 (2019-09-10) #

Fixes:

  • Properly import IOClient

2.0.0 (2019-08-12) #

Features:

  • rewrite for server side one-time payments with checkout

1.2.2 (2016-10-20) #

Features:

  • upgrade dependencies

Bug fixes:

  • change card type to card brand

1.2.1 (2016-08-08) #

Features:

  • add CHANGELOG.md (closes #32)
  • add default source to customer (#33, @rbellens)

Bug fixes:

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  stripe: ^2.0.2

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:stripe/stripe.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
76
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
50
Overall:
Weighted score of the above. [more]
78
Learn more about scoring.

We analyzed this package on Nov 4, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.6.0
  • pana: 0.12.21

Platforms

Detected platforms: Flutter, other

Primary library: package:stripe/stripe.dart with components: io.

Maintenance issues and suggestions

Support latest dependencies. (-20 points)

The version constraint in pubspec.yaml does not support the latest published versions for 2 dependencies (json_annotation, json_serializable).

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and stripe.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
crypto >=1.0.0 <3.0.0 2.1.3
http >=0.11.1 <0.13.0 0.12.0+2
json_annotation ^2.3.0 2.3.0 3.0.0
json_serializable ^2.0.0 2.3.0 3.2.3
logging ^0.11.3 0.11.3+2
meta ^1.1.7 1.1.8
Transitive dependencies
analyzer 0.36.4 0.39.1
args 1.5.2
async 2.4.0
build 1.2.1
build_config 0.4.1+1
charcode 1.1.2
checked_yaml 1.0.2
collection 1.14.12
convert 2.1.1
csslib 0.16.1
dart_style 1.2.9 1.3.3
front_end 0.1.19 0.1.29
glob 1.2.0
html 0.14.0+3
http_parser 3.1.3
js 0.6.1+1
kernel 0.3.19 0.3.29
node_interop 1.0.3
node_io 1.0.1+2
package_config 1.1.0
path 1.6.4
pub_semver 1.4.2
pubspec_parse 0.1.5
source_gen 0.9.4+4 0.9.4+6
source_span 1.5.5
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6
watcher 0.9.7+12
yaml 2.2.0
Dev dependencies
build_runner ^1.0.0
grinder ^0.8.1
pedantic ^1.8.0 1.8.0+1
test ^1.3.0