stream_ext 0.4.0

  • README.md
  • Installing
  • Versions
  • 35

stream_ext #

Build Status

This is a port of the Rx functions for working with Dart's Stream type, which already has the basic set of Rx APIs such as select and where.

This library adds the more 'exotic' Rx functions such as delay, buffer, scan, throttle, zip, merge, etc. to help make working with Dart's Stream type even easier!

Getting Started #

To get up to speed with stream_ext:

  • have a look at the Getting Started document
  • the wiki also contains details (including marble diagrams) for each of the functions
  • the example directory also contains more useful/meaningful usages for each of the functions

Feedbacks #

I would love to know what you think of this project, and where it might be improved. Please feel free to get in touch if you have any questions about this project.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  stream_ext: ^0.4.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:stream_ext/stream_ext.dart';
  
Version Uploaded Documentation Archive
0.4.0 Jul 2, 2014 Go to the documentation of stream_ext 0.4.0 Download stream_ext 0.4.0 archive
0.3.0 Sep 25, 2013 Go to the documentation of stream_ext 0.3.0 Download stream_ext 0.3.0 archive
0.2.0 Sep 18, 2013 Go to the documentation of stream_ext 0.2.0 Download stream_ext 0.2.0 archive
0.1.0 Sep 11, 2013 Go to the documentation of stream_ext 0.1.0 Download stream_ext 0.1.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
69
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
35
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.