stackexchange 0.0.1
stackexchange: ^0.0.1

Dart native js
Flutter Android iOS web

Dart implementation of Stackexchange API

1
likes
65 / 110
pub points
0 %
popularity

We analyzed this package on Nov 27, 2020, and awarded it 65 pub points (of a possible 110):

Follow Dart file conventions
5 / 20

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://github.com/yogesh-aggarwal/stackexchange-dart was unreachable.

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

0/5 points: Provide a valid CHANGELOG.md

No `CHANGELOG.md` found.

Changelog entries help developers follow the progress of your package. See the example generated by stagehand.

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 0 out of 23 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 12 issues. Showing the first 2:

INFO: Don't type annotate initializing formals.

lib/answers.dart:18:5

   ╷
18 │     int this.page: 1,
   │     ^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/answers.dart

INFO: Use `=` to separate a named parameter from its default value.

lib/answers.dart:18:18

   ╷
18 │     int this.page: 1,
   │                  ^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/answers.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
http^0.12.00.12.20.12.2
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.1.31.1.3
collection-1.14.131.14.13
http_parser-3.1.43.1.4
meta-1.2.41.2.4
path-1.7.01.7.0
pedantic-1.9.21.9.2
source_span-1.7.01.7.0
string_scanner-1.0.51.0.5
term_glyph-1.1.01.1.0
typed_data-1.2.01.2.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

1
likes
65
pub points
0%
popularity

Dart implementation of Stackexchange API

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

developeryogeshgit@gmail.com

License

GPL 3.0 (LICENSE)

Dependencies

http

More

Packages that depend on stackexchange