srec_codec 0.0.4

  • Readme
  • Changelog
  • Example
  • Installing
  • 0

srec_codec #

Dart library to parse and write motorola SREC

Usage #

A simple usage example:

import 'dart:io';
import 'package:srec_codec/srec_codec.dart';

main() async {
  final String filename = 'data/unnamed/iodesc_iqs.hps';
  File file = new File(filename);
  final result = await parse(file.openRead());

Features and bugs #

Please file feature requests and bugs at the issue tracker.

Changelog #

0.0.4 #

  • srec2view command line utility
  • Bug fixes

0.0.3 #

  • SRec writer
  • Lot of convenient 'to' and 'parse' functions for SRec and SRecView

0.0.2 #

  • Added parseSrecView and toSrecView methods to handle SREC view
  • Added view2srec command line utility to convert from SREC view to SREC file

0.0.1 #

  • Initial version, created by Stagehand


// Copyright (c) 2017, Ravi Teja Gudapati. All rights reserved. Use of this source code
// is governed by a BSD-style license that can be found in the LICENSE file.

import 'dart:io';
import 'package:srec_codec/srec_codec.dart';

main() async {
  final String filename = 'data/srecs/iodesc_iqs.srec';
  File file = new File(filename);
  final result = await SRec.parseRecordsByteStream(file.openRead());

Use this package as an executable

1. Install it

You can install the package from the command line:

$ pub global activate srec_codec

2. Use it

The package has the following executables:

$ srec2view
$ view2srec

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  srec_codec: ^0.0.4

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:srec_codec/srec_codec.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.0 <2.0.0