square 0.0.2

  • Readme
  • Changelog
  • Example
  • Installing
  • 48

Square #

This package contains a single widget. A square switch, in future i pretend to add some other widgets made for me.

Getting started #

To use it you need add as dependency to your project.

    square: ^0.0.2

Importing #

import 'package:square/square.dart';

Usage #

Make sure importing the library before try to use it

import 'package:square/square.dart';
    activeTrackColor: Colors.blue,
    inactiveTrackColor: Colors.cyan,
    onChange: () {},

alt text

[0.0.2]. #

  • Fixing example of how to add this library to dependencies.


import 'package:flutter/material.dart';
import 'example.dart';


class MyApp extends StatelessWidget {
  Widget build(BuildContext context) {
    return MaterialApp(
      home: Example(),

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  square: ^0.0.2

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:square/square.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Jun 5, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.2
  • pana: 0.13.8-dev
  • Flutter: 1.17.1

Health suggestions

Format lib/square.dart.

Run flutter format to format lib/square.dart.

Format lib/src/square_switch.dart.

Run flutter format to format lib/src/square_switch.dart.

Maintenance suggestions

The package description is too short. (-12 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.12
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies