Add the library to your specs:
dependencies: sqlite: ^0.5.0
Add this to your package's pubspec.yaml file:
dependencies: sqlite2: ^0.5.1
You can install packages from the command line:
$ pub get
Alternatively, your editor might support
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
We analyzed this package on Jul 22, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:
Detected platforms: other
Platform components identified in package:
lib/sqlite.dart. (-0.50 points)
lib/sqlite.dart reported 1 hint:
line 57 col 15: This function has a return type of 'Future', but doesn't end with a return statement.
Use constrained dependencies. (-20 points)
pubspec.yaml contains 3 dependencies without version constraints. Specify version ranges for the following dependencies:
Homepage URL doesn't exist. (-20 points)
At the time of the analysis the
https://github.com/l7ssha/dart-sqlite was unreachable.
analysis_options.yaml. (-10 points)
Change the name of your package's
.analysis_options file to
The package description is too short. (-14 points)
Add more detail to the
description field of
pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.
Maintain an example.
None of the files in the package's
example/ directory matches known example patterns.
Common filename patterns include
sqlite2.dart. Packages with multiple examples should provide
For more information see the pub package layout conventions.
|Dart SDK||>=1.8.3 <3.0.0|