sqlite2 0.5.1

  • Readme
  • Changelog
  • Installing
  • 65

SQLite bindings for the Dart VM #

Build status

Installation #

Add the library to your specs:

dependencies:
  sqlite: ^0.5.0

Documentation #

See the examples for how to use the library and the pub.dartlang.org page for the API documentation.

0.5.0 #

  • Adapted lib to Dart 2.0
  • Removed deprecated code

0.4.0 #

  • Dynamic getters
  • Working examples
  • New async-friendly API

0.3.0 #

  • Updated to run on Dart 1.15.0
  • Removed Windows support
  • Package publication support

0.2 #

  • Even better stuff

0.1 #

  • Genesis of the good stuff

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  sqlite2: ^0.5.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:sqlite2/sqlite.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
57
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
33
Overall:
Weighted score of the above. [more]
65
Learn more about scoring.

We analyzed this package on Oct 21, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.1
  • pana: 0.12.21

Platforms

Detected platforms: other

Platform components identified in package: nativewrappers.

Health suggestions

Fix lib/sqlite.dart. (-0.50 points)

Analysis of lib/sqlite.dart reported 1 hint:

line 57 col 15: This function has a return type of 'Future', but doesn't end with a return statement.

Maintenance issues and suggestions

Use constrained dependencies. (-20 points)

The pubspec.yaml contains 3 dependencies without version constraints. Specify version ranges for the following dependencies: http, path, yaml.

Homepage URL doesn't exist. (-20 points)

At the time of the analysis the homepage field https://github.com/l7ssha/dart-sqlite was unreachable.

Use analysis_options.yaml. (-10 points)

Change the name of your package's .analysis_options file to analysis_options.yaml.

Read more about the setup of analysis-options.yaml.

The package description is too short. (-14 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is getting outdated. (-3.01 points)

The package was last published 53 weeks ago.

Maintain an example.

None of the files in the package's example/ directory matches known example patterns.

Common filename patterns include main.dart, example.dart, and sqlite2.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.8.3 <3.0.0
http any 0.12.0+2
path any 1.6.4
yaml any 2.2.0
Transitive dependencies
async 2.4.0
charcode 1.1.2
collection 1.14.12
http_parser 3.1.3
meta 1.1.7
pedantic 1.8.0+1
source_span 1.5.5
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6
Dev dependencies
test any