sqlcool 4.3.1
sqlcool: ^4.3.1 copied to clipboard

Easy and reactive Sqlite. Stream of changes, select bloc, custom database models

37
likes
80/ 130
pub points
79%
popularity

We analyzed this package on Nov 23, 2021, and awarded it 80 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 157 out of 160 API elements (98.1 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 9 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `Web`.

Because:

  • package:sqlcool/sqlcool.dart that imports:
  • package:sqlcool/src/schema/models/dbmodels.dart that imports:
  • package:sqlcool/src/database.dart that imports:
  • package:sqflite/sqflite.dart that declares support for platforms: Android, iOS, macOS.
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/src/database.dart doesn't match the Dart formatter.

To format your files run: flutter format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
cupertino_icons^0.1.20.1.31.0.4
extra_pedantic^1.1.1+31.5.01.5.0
flutterflutter0.0.00.0.0
path_provider^1.6.01.6.282.0.7
pedantic^1.8.01.11.11.11.1
sqflite^1.2.01.3.2+42.0.0+4
synchronized^2.2.02.2.0+23.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.2.0
collection-1.15.01.15.0
ffi-1.1.21.1.2
file-6.1.26.1.2
meta-1.7.01.7.0
path-1.8.01.8.0
path_provider_linux-0.0.1+22.1.2
path_provider_macos-0.0.4+82.0.3
path_provider_platform_interface-1.0.42.0.1
path_provider_windows-0.0.52.0.4
platform-3.0.23.0.2
plugin_platform_interface-1.0.32.0.2
process-4.2.44.2.4
sky_engine-0.0.990.0.99
sqflite_common-1.0.3+32.0.1+1
typed_data-1.3.01.3.0
vector_math-2.1.02.1.1
win32-2.3.02.3.0
xdg_directories-0.1.20.2.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 4 issues. Showing the first 2:

The constraint `^0.1.2` on cupertino_icons does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions cupertino_icons to update the constraint.

The constraint `^1.6.0` on path_provider does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions path_provider to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.2.2 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.4, Flutter 2.5.3, Dart 2.14.4.

37
likes
80
pub points
79%
popularity

Easy and reactive Sqlite. Stream of changes, select bloc, custom database models

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

cupertino_icons, extra_pedantic, flutter, path_provider, pedantic, sqflite, synchronized

More

Packages that depend on sqlcool