spider_lee 0.1.3

  • Readme
  • Changelog
  • Example
  • Installing
  • 63

spider_lee #

Spider Lee Plugin for Flutter. Supports Android and iOS platforms.

0.1.0 #

  • Initial release for Android and iOS.

0.1.1 #

  • Bug fixed.

0.1.2 #

  • Bug fixed.

0.1.3 #

  • Linux root added and Bug fixed.

example/lib/main.dart

import 'package:flutter/material.dart';

void main() => runApp(MyApp());

class MyApp extends StatelessWidget {
  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      title: 'Welcome to Flutter',
      home: Scaffold(
        appBar: AppBar(
          title: Text('Welcome to Flutter'),
        ),
        body: Center(
          child: Text('Hello World'),
        ),
      ),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  spider_lee: ^0.1.3

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:spider_lee/spider_lee.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
43
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
60
Overall:
Weighted score of the above. [more]
63
Learn more about scoring.

We analyzed this package on Jul 11, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.15
  • Flutter: 1.17.5

Analysis suggestions

Package does not support Flutter platform Linux

Because:

  • package:spider_lee/spider_lee.dart that declares support for platforms: Android, iOS

Package does not support Flutter platform Web

Because:

  • package:spider_lee/spider_lee.dart that declares support for platforms: Android, iOS

Package does not support Flutter platform Windows

Because:

  • package:spider_lee/spider_lee.dart that declares support for platforms: Android, iOS

Package does not support Flutter platform macOS

Because:

  • package:spider_lee/spider_lee.dart that declares support for platforms: Android, iOS

Package not compatible with SDK dart

Because:

  • spider_lee that is a package requiring null.

Health suggestions

Format lib/spider_lee.dart.

Run flutter format to format lib/spider_lee.dart.

Maintenance issues and suggestions

Homepage URL doesn't exist. (-20 points)

At the time of the analysis the homepage field https://github.com/vinodlee/spider-meet was unreachable.

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.12 1.14.13
meta 1.1.8 1.2.2
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
vector_math 2.0.8 2.1.0-nullsafety
Dev dependencies
flutter_test