source_gen_helpers 0.0.2

  • Readme
  • Changelog
  • Installing
  • 39

Dart Source Generation Helpers #

This package collects some basic patters commonly used for source generation.

Changelog #

0.0.2 #

  • Added operators
  • Added generic arguments
  • Generator overrides are normal methods (not flagged with async or async*)

0.0.1 #

Initial version

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  source_gen_helpers: ^0.0.2

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:source_gen_helpers/class/class_visitor.dart';
import 'package:source_gen_helpers/class/output_visitor.dart';
import 'package:source_gen_helpers/class/override_visitor.dart';
import 'package:source_gen_helpers/class/util.dart';
import 'package:source_gen_helpers/filter_generator.dart';
import 'package:source_gen_helpers/test/generation.dart';
import 'package:source_gen_helpers/test/test_classes.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
1
Health:
Code health derived from static analysis. [more]
91
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
55
Overall:
Weighted score of the above. [more]
39
Learn more about scoring.

We analyzed this package on Jan 16, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.0
  • pana: 0.13.4

Health suggestions

Fix lib/class/util.dart. (-3.45 points)

Analysis of lib/class/util.dart reported 7 hints, including:

line 35 col 1: The class 'Future' wasn't exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.

line 36 col 20: The class 'Future' wasn't exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.

line 37 col 8: The class 'Future' wasn't exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.

line 38 col 16: The class 'Future' wasn't exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.

line 58 col 13: Unnecessary new keyword.

Fix lib/test/generation.dart. (-2.96 points)

Analysis of lib/test/generation.dart reported 6 hints, including:

line 15 col 13: 'classElements' is deprecated and shouldn't be used. Use classes instead.

line 24 col 13: Unnecessary new keyword.

line 30 col 23: Unnecessary new keyword.

line 32 col 20: Unnecessary new keyword.

line 40 col 11: Unnecessary new keyword.

Fix lib/class/class_visitor.dart. (-1 points)

Analysis of lib/class/class_visitor.dart reported 2 hints:

line 10 col 57: Unnecessary new keyword.

line 11 col 55: Unnecessary new keyword.

Fix lib/class/override_visitor.dart. (-1 points)

Analysis of lib/class/override_visitor.dart reported 2 hints:

line 58 col 25: Unnecessary new keyword.

line 113 col 25: Unnecessary new keyword.

Fix lib/class/output_visitor.dart. (-0.50 points)

Analysis of lib/class/output_visitor.dart reported 1 hint:

line 10 col 26: Unnecessary new keyword.

Maintenance issues and suggestions

Support latest dependencies. (-20 points)

The version constraint in pubspec.yaml does not support the latest published versions for 2 dependencies (analyzer, build_config).

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and source_gen_helpers.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

The package description is too short. (-5 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev <3.0.0
analyzer ^0.33.6 0.33.6+1 0.39.4
build ^1.0.2 1.1.0 1.2.2
build_config ^0.3.1 0.3.2 0.4.1+1
build_runner ^1.1.2 1.2.3 1.7.3
build_test ^0.10.4 0.10.6 0.10.12
source_gen ^0.9.2 0.9.4+1 0.9.4+7
test ^1.5.1 1.5.3 1.11.0
Transitive dependencies
args 1.5.2
async 2.4.0
boolean_selector 1.0.5
build_daemon 0.2.3 2.1.3
build_resolvers 0.2.3 1.3.1
build_runner_core 2.0.1 4.3.0
built_collection 4.3.2
built_value 6.7.1 7.0.8
charcode 1.1.2
checked_yaml 1.0.2
code_builder 3.2.0 3.2.1
collection 1.14.12
convert 2.1.1
crypto 2.1.4
csslib 0.14.6+1 0.16.1
dart_style 1.2.0 1.3.3
fixnum 0.10.11
front_end 0.1.6+9 0.1.29
glob 1.2.0
graphs 0.2.0
html 0.14.0 0.14.0+3
http 0.12.0+4
http_multi_server 2.1.0
http_parser 3.1.3
io 0.3.3
js 0.6.1+1
json_annotation 2.4.0 3.0.1
json_rpc_2 2.1.0
kernel 0.3.6+9 0.3.29
logging 0.11.4
matcher 0.12.3+1 0.12.6
meta 1.1.8
mime 0.9.6+3
multi_server_socket 1.0.2
node_interop 1.0.3
node_io 1.0.1+2
node_preamble 1.4.8
package_config 1.1.0
package_resolver 1.0.10
path 1.6.4
pedantic 1.9.0
plugin 0.2.0+3
pool 1.4.0
pub_semver 1.4.2
pubspec_parse 0.1.5
quiver 2.0.5 2.1.2+1
shelf 0.7.5
shelf_packages_handler 1.0.4
shelf_static 0.2.8
shelf_web_socket 0.2.3
source_map_stack_trace 1.1.5
source_maps 0.10.8
source_span 1.6.0
stack_trace 1.9.3
stream_channel 1.7.0 2.0.0
stream_transform 0.0.20 1.1.0
string_scanner 1.0.5
term_glyph 1.1.0
test_api 0.2.2 0.2.12
test_core 0.2.1+1 0.2.17
timing 0.1.1+2
typed_data 1.1.6
vm_service_client 0.2.6+3
watcher 0.9.7+13
web_socket_channel 1.1.0
yaml 2.2.0