socket_mvvm 0.0.1

  • Readme
  • Changelog
  • Installing
  • 36

金智囊socket通讯的mvvm架构 #

1.在你的的顶层布局使用ProviderWidget, 比如: ProviderWidget

2.构建你的model,继承ViewStateModel

3.构建数据来源,继承BaseRepository

[0.0.1] - TODO: Add release date. #

  • TODO: Describe initial release.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  socket_mvvm: ^0.0.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:socket_mvvm/provider/ProviderWidget.dart';
import 'package:socket_mvvm/socket/repository/BaseRepository.dart';
import 'package:socket_mvvm/socket/config/SocketConfig.dart';
import 'package:socket_mvvm/socket/vm/ViewState.dart';
import 'package:socket_mvvm/socket/vm/ViewStateModel.dart';
import 'package:socket_mvvm/socket/StartService.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
30
Overall:
Weighted score of the above. [more]
36
Learn more about scoring.

We analyzed this package on Mar 31, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.6
  • Flutter: 1.12.13+hotfix.8

Health suggestions

Fix lib/socket/repository/BaseRepository.dart. (-1 points)

Analysis of lib/socket/repository/BaseRepository.dart reported 2 hints:

line 20 col 12: Avoid wrapping fields in getters and setters just to be "safe".

line 22 col 7: Avoid wrapping fields in getters and setters just to be "safe".

Format lib/provider/ProviderWidget.dart.

Run flutter format to format lib/provider/ProviderWidget.dart.

Format lib/socket/StartService.dart.

Run flutter format to format lib/socket/StartService.dart.

Format lib/socket/vm/ViewState.dart.

Run flutter format to format lib/socket/vm/ViewState.dart.

Format lib/socket/vm/ViewStateModel.dart.

Run flutter format to format lib/socket/vm/ViewStateModel.dart.

Maintenance issues and suggestions

The description contains too many non-ASCII characters. (-20 points)

The site uses English as its primary language. The value of the description field in your package's pubspec.yaml field should primarily contain characters used in English.

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (provider).

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and socket_mvvm.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
provider ^3.1.0 3.2.0 4.0.4
web_socket_channel ^1.1.0 1.1.0
Transitive dependencies
async 2.4.1
charcode 1.1.3
collection 1.14.11 1.14.12
convert 2.1.1
crypto 2.1.4
meta 1.1.8
sky_engine 0.0.99
stream_channel 2.0.0
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test