social_foundation 0.0.18-beta7
social_foundation: ^0.0.18-beta7 copied to clipboard

social foundation

0
likes
60 / 110
pub points
22 %
popularity

We analyzed this package on Mar 27, 2021, and awarded it 60 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 29 out of 678 API elements (4.3 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 9 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:social_foundation/social_foundation.dart that declares support for platforms: Android, iOS
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 50 issues. Showing the first 2:

INFO: 'cursorColor' is deprecated and shouldn't be used. Use TextSelectionThemeData.cursorColor instead. This feature was deprecated after v1.23.0-4.0.pre..

lib/states/app_state.dart:90:7

   ╷
90 │       cursorColor: themeData.accentColor,
   │       ^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/states/app_state.dart

INFO: 'textSelectionColor' is deprecated and shouldn't be used. Use TextSelectionThemeData.selectionColor instead. This feature was deprecated after v1.23.0-4.0.pre..

lib/states/app_state.dart:94:7

   ╷
94 │       textSelectionColor: themeData.accentColor.withAlpha(60),
   │       ^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/states/app_state.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
audioplayers^0.14.00.14.20.18.1
bot_toast^2.3.02.4.14.0.1
cached_network_image^2.2.02.3.33.0.0
common_utils^1.2.11.2.42.0.2
crypto^2.1.32.1.53.0.0
dio^3.0.93.0.103.0.10
event_bus^1.1.11.1.12.0.0
extended_image^0.9.00.9.04.0.0
flutterflutter0.0.00.0.0
flutter_cache_manager^1.1.31.4.23.0.0
flutter_plugin_record^0.1.70.1.91.0.0
flutter_screenutil^1.1.01.1.04.0.4
flutter_spinkit^4.1.24.1.2+15.0.0
fluwx^2.1.02.6.23.3.0
get_it^3.1.03.1.06.0.0
http^0.12.0+40.12.20.13.1
image_picker^0.6.3+40.6.7+220.7.3
leancloud_official_plugin^1.0.0-beta.61.0.0-beta.121.0.0-beta.12
path^1.6.41.8.01.8.0
path_provider^1.6.01.6.282.0.1
provider^4.0.44.3.35.0.0
pull_to_refresh^1.5.81.6.41.6.4
shared_preferences^0.5.6+30.5.12+42.0.5
shimmer^1.1.11.1.21.1.2
sqflite^1.2.01.3.2+42.0.0+3
uuid^2.0.42.2.23.0.2
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
charcode-1.2.01.2.0
clock-1.1.01.1.0
collection-1.15.01.15.0
convert-2.1.13.0.0
decimal-1.0.01.0.0
extended_image_library-0.2.33.0.0
ffi-1.0.01.0.0
file-6.1.06.1.0
flutter_blurhash-0.5.00.6.0
flutter_plugin_android_lifecycle-1.0.112.0.0
flutter_web_plugins-0.0.00.0.0
http_client_helper-0.2.12.0.2
http_parser-3.1.44.0.0
image_picker_platform_interface-1.1.62.0.1
intl-0.17.00.17.0
js-0.6.30.6.3
meta-1.3.01.3.0
nested-1.0.01.0.0
octo_image-0.3.01.0.0
path_provider_linux-0.0.1+22.0.0
path_provider_macos-0.0.4+82.0.0
path_provider_platform_interface-1.0.42.0.1
path_provider_windows-0.0.52.0.0
pedantic-1.11.01.11.0
platform-3.0.03.0.0
plugin_platform_interface-1.0.32.0.0
process-4.2.14.2.1
rational-1.0.01.0.0
rxdart-0.24.10.26.0
shared_preferences_linux-0.0.2+42.0.0
shared_preferences_macos-0.0.1+112.0.0
shared_preferences_platform_interface-1.0.42.0.0
shared_preferences_web-0.1.2+72.0.0
shared_preferences_windows-0.0.2+32.0.0
sky_engine-0.0.990.0.99
source_span-1.8.11.8.1
sqflite_common-1.0.3+32.0.0+2
string_scanner-1.1.01.1.0
synchronized-2.2.0+23.0.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0
win32-2.0.52.0.5
xdg_directories-0.1.20.2.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 20 issues. Showing the first 2:

The constraint `^0.14.0` on audioplayers does not support the stable version `0.15.0`.

Try running dart pub upgrade --major-versions audioplayers to update the constraint.

The constraint `^2.3.0` on bot_toast does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions bot_toast to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.4, Flutter 2.0.3, Dart 2.12.2.