snaxdart_errors 1.0.0

Build Status

snax_errors #

Basic snax errors library

NamecodeDescription
AlreadyExistsError1Means that something already exists
BadRequestError2Means that request payload is not valid
NotFoundError3Means that something not found
GeneralError4Means that this error is representing common error and cannot be associated with other error types
TwitterError5Means that this error was returned from Twitter API
SteemitError6Means that this error was returned from Steemit Chain
RestrictionError7Means that not authenticated or not allowed
InternalServerError8Means that something in general wrong with the server side
ResourcesUsageError9Means that user don't have enough resources to send transactions to the chain

1.0.0 #

  • First release

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  snaxdart_errors: ^1.0.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:snaxdart_errors/snaxdart_errors.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
45
Health:
Code health derived from static analysis. [more]
98
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
66
Learn more about scoring.

We analyzed this package on Jul 20, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.4.0
  • pana: 0.12.19

Platforms

Detected platforms: Flutter, web, other

No platform restriction found in primary library package:snaxdart_errors/snaxdart_errors.dart.

Health issues and suggestions

Document public APIs. (-1 points)

34 out of 34 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Fix lib/snaxdart_errors.g.dart. (-1 points)

Analysis of lib/snaxdart_errors.g.dart reported 2 hints:

line 9 col 11: The function '_$SnaxErrorFromJson' isn't used.

line 17 col 22: The function '_$SnaxErrorToJson' isn't used.

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and snaxdart_errors.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
json_annotation ^2.2.0 2.4.0
Dev dependencies
build_runner ^1.3.3
json_serializable ^2.2.0
test ^1.6.4

Admin