simplegamelib 0.0.4

  • Readme
  • Changelog
  • Installing
  • 0

simplegamelib #

Heads Up - this is a very early release!

An easy to use package for 2D games. It is going to be awesome.

Usage #

A simple usage example:

import 'dart:html';
import 'package:simplegamelib/simplegamelib.dart';

void main() {
  Game game = new Game("My Game", '#surface');
  Sprite player = game.createSprite("images/ninjadude.png");

  player
    ..position = new Point(0, 10)
    ..movement = Movements.east;
	
  print('starting game...');
  game.start();
}

Features and bugs #

Github : https://github.com/daftspaniel/simplegamelib

To run unit tests. #

pub run test .\test\simplegamelib_test.dart -p dartium

Changelog #

0.0.4 #

  • Added more comments to Game object.
  • Added optional custom update hook to simplify demos.

0.0.3 #

  • Added URL of homepage for package.

0.0.2 #

  • HomepageUrl in Readme updated.
  • Print statement commented out.

0.0.1 #

  • Initial version to allow Demo 1 to use pub version rather than local.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  simplegamelib: ^0.0.4

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:simplegamelib/simplegamelib.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

This package version is not analyzed, because it is more than two years old. Check the latest stable version for its analysis.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.0.0 <2.0.0