simple_server 0.2.1

  • Installing
  • Versions
  • 0

SimpleServer #

Installation #

Add it to your dependencies

  simple_server: any

and install the package

$ pub get

Usage #

import 'dart:io';
import 'package:simple_server/simple_server.dart';
main() async {
    server = new SimpleServer("/", "/docroot");
    bool serverStarted = await server.start();

    if (serverStarted == true) {
        /* Web pages */
        server.route(url: "/",      responser: new FileResponse("docroot/index.html"))

Contributing #

  1. Fork it!
  2. Create your feature branch: git checkout -b my-new-feature
  3. Commit your changes: git commit -am 'Add some feature'
  4. Push to the branch: git push origin my-new-feature
  5. Submit a pull request :D

Credits #

Robert Beyer

License #


0.2.1 (2015-10-21) #

  • increase debs

0.1.1 (2015-09-07) #

  • add port getter

0.1.0 (2015-09-07) #

  • project start

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  simple_server: ^0.2.1

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:simple_server/simple_server.dart';
Version Uploaded Documentation Archive
0.2.1 Oct 21, 2015 Go to the documentation of simple_server 0.2.1 Download simple_server 0.2.1 archive
0.2.0 Oct 16, 2015 Go to the documentation of simple_server 0.2.0 Download simple_server 0.2.0 archive
0.1.1 Sep 7, 2015 Go to the documentation of simple_server 0.1.1 Download simple_server 0.1.1 archive
0.1.0 Sep 7, 2015 Go to the documentation of simple_server 0.1.0 Download simple_server 0.1.0 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >1.12.0