A simplified FutureBuilder for the most common use case when working with Futures in Flutter.
This package is hardly necessary, but it saves you a little typing.
Getting Started #
Usage is really simple. Just import
and then in your code, suppose you have some computation that is completing in the future, like
Future<String> getAsyncVersion(). Type:
SimpleFutureBuilder<String>( future: getAsyncVersion(), builder: (BuildContext context, String result) => Text(result), )
Please note, if you want to deal with full error handling based on the results of the future, you will instead need to use the FutureBuilder widget.
[1.0.1] - 12/28/18
- Added example directory and fixed typing of builder parameter.
[1.0.0] - 12/28/18
- Initial implementation of SimpleFutureBuilder
A new Flutter project.
Getting Started #
This project is a starting point for a Flutter application.
A few resources to get you started if this is your first Flutter project:
For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.
Use this package as a library
1. Depend on it
Add this to your package's pubspec.yaml file:
dependencies: simple_future_builder: ^1.0.1
2. Install it
You can install packages from the command line:
$ flutter pub get
Alternatively, your editor might support
flutter pub get.
Check the docs for your editor to learn more.
3. Import it
Now in your Dart code, you can use:
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
We analyzed this package on Feb 13, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:
- Dart: 2.7.1
- pana: 0.13.5
- Flutter: 1.12.13+hotfix.7
lib/simple_future_builder.dart. (-0.50 points)
lib/simple_future_builder.dart reported 1 hint:
line 21 col 9: The class 'Future' wasn't exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.
Package is getting outdated. (-12.60 points)
The package was last published 58 weeks ago.