schmucklicloud_storage 1.0.0 icon indicating copy to clipboard operation
schmucklicloud_storage: ^1.0.0 copied to clipboard

The official schmuckliCloud Storage SDK for Dart. Use this SDK if you want store and manage data from the Cloud.

1
likes
100/ 140
pub points
0%
popularity

We analyzed this package 3 days ago, and awarded it 100 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
30 / 30icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

10/10 points: 20% or more of the public API has dartdoc comments

  • 10 out of 27 API elements (37.0 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS
  • ✓ Web
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 17 issues. Showing the first 2:

INFO: Name non-constant identifiers using lowerCamelCase.

lib/config.dart:1:8

  ╷
1 │ String api_endpoint = "https://api.schmuckli.cloud/client_api/v1/data/";
  │        ^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/config.dart

INFO: Name source files using lowercase_with_underscores.

To reproduce make sure you are using the lints_core and run dart analyze lib/sCNotify.dart

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
http^0.12.00.12.20.13.5
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.3.11.3.1
collection-1.17.01.17.0
http_parser-3.1.44.0.2
path-1.8.31.8.3
pedantic-1.11.11.11.1
source_span-1.9.11.9.1
string_scanner-1.2.01.2.0
term_glyph-1.2.11.2.1
typed_data-1.3.11.3.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint ^0.12.0 on http does not support the stable version 0.13.0.

Try running dart pub upgrade --major-versions http to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint >=2.0.0 <3.0.0) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.21, Dart 2.18.4.

1
likes
100
pub points
0%
popularity

Publisher

verified publisher iconschmuckli.cloud

The official schmuckliCloud Storage SDK for Dart. Use this SDK if you want store and manage data from the Cloud.

Homepage
Repository (GitHub)
View/report issues

Documentation

Documentation
API reference

License

Icon for licenses.MIT (LICENSE)

Dependencies

http

More

Packages that depend on schmucklicloud_storage