rw_speech_recognizer 1.0.0

  • Readme
  • Changelog
  • Example
  • Installing
  • 60

rw_speech_recognizer #

Speech recognizer plugin for RealWear HMT-1(Z1).

Usage #

    RwSpeechRecognizer.setCommands(<String>[
      'Full Boar',
      'California Sunshine',
      'Deadicated',
    ], (command) {
      // Define your callback here
    });

1.0.0 #

  • Initial release.

example/lib/main.dart

import 'package:flutter/material.dart';

import 'package:rw_speech_recognizer/rw_speech_recognizer.dart';

void main() => runApp(MyApp());

class MyApp extends StatefulWidget {
  @override
  _MyAppState createState() => _MyAppState();
}

class _MyAppState extends State<MyApp> {
  String _speechCommand;

  @override
  void initState() {
    super.initState();

    RwSpeechRecognizer.setCommands(<String>[
      'Full Boar',
      'California Sunshine',
      'Deadicated',
    ], (command) {
      setState(() {
        _speechCommand = command;
      });
    });
  }

  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      home: Scaffold(
        appBar: AppBar(
          title: const Text(
              'RealWear HMT-1 speech recognition plugin example app'),
        ),
        body: Builder(builder: (BuildContext context) {
          if (_speechCommand != null) {
            WidgetsBinding.instance.addPostFrameCallback((_) {
              showDialog(
                context: context,
                builder: (BuildContext context) {
                  return AlertDialog(
                    title: Text(''),
                    content: Text('You said $_speechCommand'),
                    actions: <Widget>[
                      new FlatButton(
                        child: const Text('OK'),
                        onPressed: () {
                          Navigator.of(context).pop();
                        },
                      ),
                    ],
                  );
                },
              );
            });
          }

          return Center(
              child: const Text(
                  'Say "Full Boar", "California Sunshine" or "Deadicated"'));
        }),
      ),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  rw_speech_recognizer: ^1.0.0

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:rw_speech_recognizer/rw_speech_recognizer.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
25
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
87
Overall:
Weighted score of the above. [more]
60
Learn more about scoring.

We analyzed this package on Jul 10, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.14
  • Flutter: 1.17.5

Analysis suggestions

Package does not support Flutter platform linux

Because:

  • package:rw_speech_recognizer/rw_speech_recognizer.dart that declares support for platforms: android, ios

Package does not support Flutter platform macos

Because:

  • package:rw_speech_recognizer/rw_speech_recognizer.dart that declares support for platforms: android, ios

Package does not support Flutter platform web

Because:

  • package:rw_speech_recognizer/rw_speech_recognizer.dart that declares support for platforms: android, ios

Package does not support Flutter platform windows

Because:

  • package:rw_speech_recognizer/rw_speech_recognizer.dart that declares support for platforms: android, ios

Package not compatible with SDK dart

Because:

  • rw_speech_recognizer that is a package requiring null.

Maintenance suggestions

The package description is too short. (-13 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.12 1.14.13
meta 1.1.8 1.2.2
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
vector_math 2.0.8 2.1.0-nullsafety
Dev dependencies
flutter_test