runtime 1.0.0-9

  • Readme
  • Changelog
  • Installing
  • 92

Generates a replica of a application package and it's dependencies that strips dart:mirror usage so that it may be compiled.

1.0.0 #

  • Initial version, created by Stagehand

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  runtime: ^1.0.0-9

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:runtime/runtime.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
90
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
85
Overall:
Weighted score of the above. [more]
92
Learn more about scoring.

We analyzed this package on Jul 2, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.13

Analysis suggestions

Package not compatible with SDK flutter

Because it is not compatible with any of the supported runtimes: flutter-native, flutter-web

Package not compatible with runtime flutter-native on android

Because of the import of dart:mirrors via the import chain package:runtime/runtime.dartpackage:runtime/src/mirror_coerce.dartdart:mirrors

Package not compatible with runtime flutter-native on ios

Because of the import of dart:mirrors via the import chain package:runtime/runtime.dartpackage:runtime/src/mirror_coerce.dartdart:mirrors

Package not compatible with runtime flutter-native on linux

Because of the import of dart:mirrors via the import chain package:runtime/runtime.dartpackage:runtime/src/mirror_coerce.dartdart:mirrors

Package not compatible with runtime flutter-native on macos

Because of the import of dart:mirrors via the import chain package:runtime/runtime.dartpackage:runtime/src/mirror_coerce.dartdart:mirrors

Package not compatible with runtime flutter-native on windows

Because of the import of dart:mirrors via the import chain package:runtime/runtime.dartpackage:runtime/src/mirror_coerce.dartdart:mirrors

Package not compatible with runtime flutter-web on web

Because of the import of dart:mirrors via the import chain package:runtime/runtime.dartpackage:runtime/src/mirror_coerce.dartdart:mirrors

Package not compatible with runtime native-aot

Because of the import of dart:mirrors via the import chain package:runtime/runtime.dartpackage:runtime/src/mirror_coerce.dartdart:mirrors

Package not compatible with runtime web

Because of the import of dart:mirrors via the import chain package:runtime/runtime.dartpackage:runtime/src/mirror_coerce.dartdart:mirrors

Health suggestions

Fix lib/slow_coerce.dart. (-0.50 points)

Analysis of lib/slow_coerce.dart reported 1 hint:

line 62 col 8: 'CastError' is deprecated and shouldn't be used. Use TypeError instead.

Fix lib/src/mirror_coerce.dart. (-0.50 points)

Analysis of lib/src/mirror_coerce.dart reported 1 hint:

line 38 col 8: 'CastError' is deprecated and shouldn't be used. Use TypeError instead.

Format bin/create.dart.

Run dartfmt to format bin/create.dart.

Fix additional 6 files with analysis or formatting issues.

Additional issues in the following files:

  • lib/runtime.dart (Run dartfmt to format lib/runtime.dart.)
  • lib/src/build.dart (Run dartfmt to format lib/src/build.dart.)
  • lib/src/build_manager.dart (Run dartfmt to format lib/src/build_manager.dart.)
  • lib/src/compiler.dart (Run dartfmt to format lib/src/compiler.dart.)
  • lib/src/exceptions.dart (Run dartfmt to format lib/src/exceptions.dart.)
  • lib/src/generator.dart (Run dartfmt to format lib/src/generator.dart.)

Maintenance suggestions

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and runtime.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Package is pre-release. (-5 points)

Pre-release versions should be used with caution; their API can change in breaking ways.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.2.0 <3.0.0
analyzer >=0.32.0 <0.50.0 0.39.11
args ^1.5.0 1.6.0
isolate_executor ^2.0.0 2.0.2+3
meta ^1.1.5 1.1.8
pubspec_parse >=0.1.4 <1.0.0 0.1.5
yaml ^2.1.15 2.2.1
Transitive dependencies
_fe_analyzer_shared 5.0.0
async 2.4.1
charcode 1.1.3
checked_yaml 1.0.2
collection 1.14.13
convert 2.1.1
crypto 2.1.5
csslib 0.16.1
glob 1.2.0
html 0.14.0+3
js 0.6.2
json_annotation 3.0.1
node_interop 1.1.1
node_io 1.1.1
package_config 1.9.3
path 1.7.0
pub_semver 1.4.4
source_span 1.7.0
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.2.0
watcher 0.9.7+15
Dev dependencies
command_line_agent ^1.0.0-b1
pedantic ^1.0.0 1.9.0 1.9.1
test ^1.0.0