routils 0.1.0+0

  • Readme
  • Changelog
  • Example
  • Installing
  • 50

routils #

A new Flutter plugin for common utils.

Getting Started #

This project is a starting point for a Flutter plug-in package, a specialized package that includes platform-specific implementation code for Android and/or iOS.

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

0.1.0+0 #

  • A new Flutter plugin for common utils, such as String & Date & Log & Regex etc. And We will continue to update.

example/lib/main.dart

import 'package:flutter/material.dart';

import 'package:routils/routils.dart';

void main() {
  runApp(MyApp());
}

class MyApp extends StatefulWidget {
  @override
  _MyAppState createState() => _MyAppState();
}

class _MyAppState extends State<MyApp> {
  String _platformVersion = 'Unknown';

  @override
  void initState() {
    super.initState();

    ///user like this:
    RoStringUtils.isEmpty('asdasdsad');
    ///or like this:
    roStringIsEmpty('textasdasd');


  }

  @override
  Widget build(BuildContext context) {
    List list = ['asdasd', 'asdasdasd'];
    Map map = {'asd':123};
    Set set = Set();
    Iterable it = Iterable.empty();
    String string = 'sadasd';

    print(roLength(list));
    print(roLength(map));
    print(roLength(set));
    print(roLength(it));
    print(roLength(string));

    return MaterialApp(
      home: Scaffold(
        appBar: AppBar(
          title: const Text('Plugin example app'),
        ),
        body: Center(
          child: Text('Running on: $_platformVersion\n'),
        ),
      ),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  routils: ^0.1.0+0

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:routils/routils.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
50
Learn more about scoring.

We analyzed this package on Jul 11, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.14
  • Flutter: 1.17.5

Analysis suggestions

Package does not support Flutter platform linux

Because:

  • package:routils/routils.dart that declares support for platforms: android, ios, macos

Package does not support Flutter platform web

Because:

  • package:routils/routils.dart that declares support for platforms: android, ios, macos

Package does not support Flutter platform windows

Because:

  • package:routils/routils.dart that declares support for platforms: android, ios, macos

Package not compatible with SDK dart

Because:

  • routils that is a package requiring null.

Health suggestions

Format lib/src/ro_list_utils.dart.

Run flutter format to format lib/src/ro_list_utils.dart.

Format lib/src/ro_utils.dart.

Run flutter format to format lib/src/ro_utils.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.7.0 <3.0.0
convert ^2.1.1 2.1.1
crypto ^2.1.3 2.1.5
flutter 0.0.0
Transitive dependencies
charcode 1.1.3
collection 1.14.12 1.14.13
meta 1.1.8 1.2.2
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
vector_math 2.0.8 2.1.0-nullsafety
Dev dependencies
flutter_test