rate_app_dialog 0.1.1+4

  • Readme
  • Changelog
  • Example
  • Installing
  • new67

What is the rate_app_dialog #

This package is designed to increase the ratings in your app, with bad review filter, find out what's bad and get more positive reviews!

To call up the dialog and request evaluation, add the following code where you think is a good place to request user evaluation or add it to your homepage within initState:

RateAppDialog(
      context: context, 
      minimeRateIsGood: 4, 
      minimeRequestToShow: 5
    )
  .requestRate();

Arguments

  • context: is required.
  • minimeRateIsGood: Optional assignment, sets the number of stars that will be requested for evaluation in the store. (default: 4)
  • minimeRequestToShow: Optional attribute, sets the number of requests to display the popup requesting the stars. (default: 5)
  • afterStarRedirect: Optional attribute, Redirect to store after user passes ratings filter. (default: false)
  • timeToShow: Optional attribute, opens the store with ideal delay for strategic points e.g. after a result expected by the user with delay of 5 seconds. (default: 0)
  • emailAdmin: Optional attribute, email will be sent to the administrator with user feedback,. (default: "")
  • customDialogIOS: Optional attribute, set true to custom dialog iOS. (default: false)

Attention: In order to be counted and displayed it will be necessary to call the method requestRate(), each call in requestRate() will be counted +1 and will be displayed according to the specified condition (minimeRequestToShow); You can specify various conditions in specific places to increase the chance of positive evaluation;

0.1.1+4 #

  • Added iOS implementation
  • update readme.md

0.1.1+3 #

  • Update gifs on readme.md
  • Update animation stars

0.1.1+2 #

  • update license package

0.1.1+1 #

  • update docs

0.1.1 #

  • add emailAdmin to send feedback
  • add timeToShow delay to show dialog

example/lib/main.dart

import 'package:flutter/material.dart';
import 'package:rate_app_dialog/rate_app_dialog.dart';

void main() {
  runApp(MyApp());
}

class MyApp extends StatelessWidget {
  // This widget is the root of your application.
  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      title: 'Flutter Demo',
      debugShowCheckedModeBanner: false,
      home: MyHomePage(title: 'Flutter Demo Home Page'),
    );
  }
}

class MyHomePage extends StatefulWidget {
  MyHomePage({Key key, this.title}) : super(key: key);

  final String title;

  @override
  _MyHomePageState createState() => _MyHomePageState();
}

class _MyHomePageState extends State<MyHomePage> {
  int _counter = 0;

  RateAppDialog rateAppDialog;

  void _incrementCounter() {
    setState(() {
      _counter++;
    });
  }

  @override
  void initState() {
    // TODO: implement initState
    super.initState();
    rateAppDialog = RateAppDialog(
        context: context,
        afterStarRedirect: false,
        customDialogIOS: true,
        minimeRequestToShow: 4,
        minimeRateIsGood: 4
    );
  }

  @override
  Widget build(BuildContext context) {
    return Scaffold(
      appBar: AppBar(
        title: Text(widget.title),
      ),
      body: Center(
        child: Column(
          mainAxisAlignment: MainAxisAlignment.center,
          children: <Widget>[
            Text(
              'You have pushed the button this many times:',
            ),
            Text(
              '$_counter',
              style: Theme.of(context).textTheme.headline4,
            ),
          ],
        ),
      ),
      floatingActionButton: FloatingActionButton(
        onPressed: () {
          rateAppDialog?.requestRate();
          _incrementCounter();
        },
        tooltip: 'Increment',
        child: Icon(Icons.add),
      ), // This trailing comma makes auto-formatting nicer for build methods.
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  rate_app_dialog: ^0.1.1+4

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:rate_app_dialog/rate_app_dialog.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
35
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
67
Learn more about scoring.

We analyzed this package on Jul 2, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.13
  • Flutter: 1.17.5

Analysis suggestions

Package does not support Flutter platform linux

Because of import path [package:rate_app_dialog/rate_app_dialog.dart] that declares support for platforms: android, ios

Package does not support Flutter platform macos

Because of import path [package:rate_app_dialog/rate_app_dialog.dart] that declares support for platforms: android, ios

Package does not support Flutter platform web

Because of import path [package:rate_app_dialog/rate_app_dialog.dart] that declares support for platforms: android, ios

Package does not support Flutter platform windows

Because of import path [package:rate_app_dialog/rate_app_dialog.dart] that declares support for platforms: android, ios

Package not compatible with SDK dart

because of import path [rate_app_dialog] that is in a package requiring null.

Health issues and suggestions

Document public APIs. (-0.08 points)

61 out of 63 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Fix lib/rate_dialog.dart. (-0.50 points)

Analysis of lib/rate_dialog.dart reported 1 hint:

line 11 col 7: This class (or a class that this class inherits from) is marked as '@immutable', but one or more of its instance fields aren't final: RateDialog.btnLater

Format lib/constants.dart.

Run flutter format to format lib/constants.dart.

Format lib/lang_texts.dart.

Run flutter format to format lib/lang_texts.dart.

Format lib/rate_app_dialog.dart.

Run flutter format to format lib/rate_app_dialog.dart.

Format lib/star_rating.dart.

Run flutter format to format lib/star_rating.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.7.0 <3.0.0
flutter 0.0.0
shared_preferences ^0.5.7+3 0.5.7+3
Transitive dependencies
collection 1.14.12 1.14.13
flutter_web_plugins 0.0.0
meta 1.1.8
shared_preferences_macos 0.0.1+10
shared_preferences_platform_interface 1.0.4
shared_preferences_web 0.1.2+7
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
vector_math 2.0.8
Dev dependencies
flutter_test