randomer 0.0.1

  • Readme
  • Changelog
  • Example
  • Installing
  • 0

randomer #

Randomer helps to you for generate what do you need.

Created from templates made available by Stagehand under a BSD-style license.

Usage #

A simple usage example:

import 'package:randomer/randomer.dart';

main() {
  print(random([true, false]));
  print(random([0, 1, 2], take: 2));
  print(capitalize('test test')); // Test test
  print(text()); // Random text
  print(text(words: 20));
  print(text(join: false)); // Will return the List
  print(text(text: ['a', 'b', 'c']));

Also, you can use the object for calling functions:

import 'package:randomer/randomer.dart';

main() {
  print(randomer.random([true, false]));
  print(randomer.random([0, 1, 2], take: 2));
  print(randomer.capitalize('test test')); // Test test
  print(randomer.text()); // Random text
  print(randomer.text(words: 20));
  print(randomer.text(join: false)); // Will return the List
  print(randomer.text(text: ['a', 'b', 'c']));

Features and bugs #

Please file feature requests and bugs at the issue tracker.

0.0.1 #

  • Initial version, created by Stagehand


import 'package:randomer/randomer.dart';

main() {
  print(random([true, false]));
  print(random([0, 1, 2]));
    {'login': 'shinda'},
    {'login': 'kioku'},
    {'login': 'first'},
    {'login': 'last'}

  print(random([0, 1, 2], take: 2));

  print(text(words: 20));
  print(text(words: 30));
  print(text(words: 20, text: ruWords));
  print(text(words: 2, text: ['first', 'second', 'third']));
  print(text(join: false)); // Will return the List

  print(capitalize('test 1 2')); // Test 1 2

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  randomer: ^0.0.1

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:randomer/randomer.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.1 <2.0.0