rain 0.0.1

  • Readme
  • Changelog
  • Example
  • Installing
  • 40

Rain

轻量、可靠的移动端 Flutter 组件库

安装 #

在你的pubspec.yaml文件的dependencies节点下添加:

rain:
    git: https://github.com/zhengzhuang96/rain.git

导入:

import 'package:rain/rain.dart';

TODO LIST: #

  • 运行中UI
  • 未来开发中
    • [ ] 表单组件
      • [ ] 开发中...
    • [ ] 反馈组件
      • [ ] 开发中...
    • [ ] 展示组件
      • [ ] 开发中...
    • [ ] 导航组件
      • [ ] 开发中...
    • [ ] 业务组件
      • [ ] 开发中...

0.0.1 #

  • TODO: Describe initial release.

example/lib/main.dart

import 'dart:io';
import 'package:flutter/material.dart';
import 'dart:async';
import 'package:flutter/services.dart';
import 'package:rain/rain.dart';
import 'package:rain_example/router/Routes.dart';

void main() {
  runApp(MyApp());
  if (Platform.isAndroid) {
    SystemUiOverlayStyle systemUiOverlayStyle =
        SystemUiOverlayStyle(statusBarColor: Colors.transparent);
    SystemChrome.setSystemUIOverlayStyle(systemUiOverlayStyle);
  }
}

class MyApp extends StatefulWidget {
  @override
  _MyAppState createState() => _MyAppState();
}

class _MyAppState extends State<MyApp> {
  String _platformVersion = 'Unknown';

  @override
  void initState() {
    super.initState();
    initPlatformState();
  }

  // Platform messages are asynchronous, so we initialize in an async method.
  Future<void> initPlatformState() async {
    String platformVersion;
    // Platform messages may fail, so we use a try/catch PlatformException.
    try {
      platformVersion = await Rain.platformVersion;
    } on PlatformException {
      platformVersion = 'Failed to get platform version.';
    }

    // If the widget was removed from the tree while the asynchronous platform
    // message was in flight, we want to discard the reply rather than calling
    // setState to update our non-existent appearance.
    if (!mounted) return;

    setState(() {
      _platformVersion = platformVersion;
    });
  }

  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      title: 'FLUTTEREUI',
      debugShowCheckedModeBanner: false,
      initialRoute: '/',  // 配置默认访问路径
      onGenerateRoute: onGenerateRoute,
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  rain: ^0.0.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:rain/rain.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
50
Overall:
Weighted score of the above. [more]
40
Learn more about scoring.

We analyzed this package on Jul 12, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.14
  • Flutter: 1.17.5

Analysis suggestions

Package does not support Flutter platform linux

Because:

  • package:rain/rain.dart that declares support for platforms: android, ios

Package does not support Flutter platform macos

Because:

  • package:rain/rain.dart that declares support for platforms: android, ios

Package does not support Flutter platform web

Because:

  • package:rain/rain.dart that declares support for platforms: android, ios

Package does not support Flutter platform windows

Because:

  • package:rain/rain.dart that declares support for platforms: android, ios

Package not compatible with SDK dart

Because:

  • rain that is a package requiring null.

Health suggestions

Format lib/rain.dart.

Run flutter format to format lib/rain.dart.

Format lib/widget/rain_appbar.dart.

Run flutter format to format lib/widget/rain_appbar.dart.

Format lib/widget/rain_cell.dart.

Run flutter format to format lib/widget/rain_cell.dart.

Maintenance issues and suggestions

The description contains too many non-ASCII characters. (-20 points)

The site uses English as its primary language. The value of the description field in your package's pubspec.yaml field should primarily contain characters used in English.

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.12 1.14.13
meta 1.1.8 1.2.2
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
vector_math 2.0.8 2.1.0-nullsafety
Dev dependencies
flutter_test