radio_plugin_test 0.0.5

  • Readme
  • Changelog
  • Installing
  • 36

DO NOT USE

DO NOT USE

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  radio_plugin_test: ^0.0.5

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:radio_plugin_test/fluttery_audio.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
96
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
36
Overall:
Weighted score of the above. [more]
36
Learn more about scoring.

We analyzed this package on Apr 4, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.6
  • Flutter: 1.12.13+hotfix.8

Health suggestions

Fix lib/src/_playlist.dart. (-1.99 points)

Analysis of lib/src/_playlist.dart reported 4 hints:

line 31 col 20: 'ancestorStateOfType' is deprecated and shouldn't be used. Use findAncestorStateOfType instead. This feature was deprecated after v1.12.1..

line 31 col 44: 'TypeMatcher' is deprecated and shouldn't be used. TypeMatcher has been deprecated because it is no longer used in framework(only in deprecated methods). This feature was deprecated after v1.12.1..

line 87 col 23: This function has a return type of 'Widget', but doesn't end with a return statement.

line 115 col 20: 'inheritFromWidgetOfExactType' is deprecated and shouldn't be used. Use dependOnInheritedWidgetOfExactType instead. This feature was deprecated after v1.12.1..

Fix lib/src/_audio_player_widgets.dart. (-1 points)

Analysis of lib/src/_audio_player_widgets.dart reported 2 hints:

line 10 col 33: 'ancestorStateOfType' is deprecated and shouldn't be used. Use findAncestorStateOfType instead. This feature was deprecated after v1.12.1..

line 10 col 57: 'TypeMatcher' is deprecated and shouldn't be used. TypeMatcher has been deprecated because it is no longer used in framework(only in deprecated methods). This feature was deprecated after v1.12.1..

Fix lib/src/_audio_player.dart. (-0.50 points)

Analysis of lib/src/_audio_player.dart reported 1 hint:

line 28 col 34: This function has a return type of 'Future', but doesn't end with a return statement.

Fix additional 3 files with analysis or formatting issues. (-0.50 points)

Additional issues in the following files:

  • lib/src/_audio_visualizer.dart (1 hint)
  • lib/fluttery_audio.dart (Run flutter format to format lib/fluttery_audio.dart.)
  • lib/src/_visualizer.dart (Run flutter format to format lib/src/_visualizer.dart.)

Maintenance issues and suggestions

Homepage URL doesn't exist. (-20 points)

At the time of the analysis the homepage field https://github.com/matthew-carroll/fluttery_audio was unreachable.

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and radio_plugin_test.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Package is getting outdated. (-3.56 points)

The package was last published 54 weeks ago.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.28.0 <3.0.0
flutter 0.0.0
logging >=0.11.3+1 <0.12.0 0.11.4
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8