pub_release 3.0.0 icon indicating copy to clipboard operation
pub_release: ^3.0.0 copied to clipboard

Automates the release of a dart package to pub.dev including running dartfmt, creating a git tag, incrementing the packages version no. and pushing the package to pub.dev.

10
likes
80/ 130
pub points
47%
popularity

We analyzed this package 22 days ago, and awarded it 80 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
20 / 20icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
10 / 20icon to trigger folding of the section

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 11 out of 47 API elements (23.4 %) have documentation comments.
icon indicating section status
Support multiple platforms
10 / 20icon to trigger folding of the section

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:pub_release/pub_release.dart that imports:
  • package:pub_release/src/version/version.dart that imports:
  • package:pub_release/src/pubspec_helper.dart that imports:
  • package:dcli/dcli.dart that imports:
  • package:dcli/src/util/wait_for_ex.dart that imports:
  • package:dcli/src/util/stack_trace_impl.dart that imports:
  • package:dcli/src/settings.dart that imports:
  • package:dcli/src/functions/env.dart that imports:
  • dart:io
icon indicating section status
Pass static analysis
30 / 30icon to trigger folding of the section

30/30 points: code has no errors, warnings, lints, or formatting issues

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
dcli^0.39.00.39.101.15.5
github^7.0.07.0.48.5.0
meta^1.2.21.7.01.7.0
mime^0.9.70.9.71.0.1
pub_semver^1.0.01.4.42.1.0
pubspec^0.1.50.1.52.0.1
settings_yaml^2.0.02.1.53.3.1
Transitive dependencies
PackageConstraintCompatibleLatest
archive-2.0.133.1.6
args-1.6.02.3.0
async-2.8.22.8.2
basic_utils-2.7.13.9.4
charcode-1.3.11.3.1
collection-1.15.01.15.0
convert-2.1.13.0.1
crypto-2.1.53.0.1
csv-4.1.05.0.1
equatable-1.2.62.0.3
ffi-0.1.31.1.2
file-5.2.16.1.2
file_utils-0.1.41.0.1
glob-1.2.02.0.2
globbing-0.3.11.0.0
http-0.12.20.13.4
http_parser-3.1.44.0.0
ini-2.1.02.1.0
intl-0.16.10.17.0
js-0.6.30.6.4
json_annotation-3.1.14.4.0
logger-0.9.41.1.0
logging-0.11.41.0.2
matcher-0.12.110.12.11
node_interop-1.2.12.1.0
node_io-1.2.02.1.0
path-1.8.11.8.1
pointycastle-2.0.13.4.0
posix-1.3.43.0.0
quiver-2.1.53.0.1+1
random_string-2.3.12.3.1
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
string_scanner-1.1.01.1.0
system_info-0.1.31.0.1
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
uri-0.11.41.0.0
uuid-2.2.23.0.5
validators-2.0.13.0.0
vin_decoder-0.1.4+10.1.4+1
yaml-2.2.13.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 6 issues. Showing the first 2:

The constraint `^0.39.0` on dcli does not support the stable version `0.40.0`.

Try running dart pub upgrade --major-versions dcli to update the constraint.

The constraint `^7.0.0` on github does not support the stable version `8.0.0`.

Try running dart pub upgrade --major-versions github to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.4, Dart 2.15.1.

10
likes
80
pub points
47%
popularity

Publisher

shield icon for verified publishersnoojee.dev

Automates the release of a dart package to pub.dev including running dartfmt, creating a git tag, incrementing the packages version no. and pushing the package to pub.dev.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

dcli, github, meta, mime, pub_semver, pubspec, settings_yaml

More

Packages that depend on pub_release