prompter_rs 0.0.1

  • Readme
  • Changelog
  • Example
  • Installing
  • 43

CLI Wizard

current version: 0.0.1

example/main.dart

import 'package:prompter_rs/prompter_rs.dart';

void main() {
  var options = [
    new Option(label: 'I want Red', value: '#f00'),
    new Option(label: 'I want Blue', value: '#00f')
  ];

  final prompter = Prompter();
  String colorCode = prompter.askMultiple('Select a Color', options);
  bool answer = prompter.askBinary('Do you like this lib');

  print(colorCode);
  print(answer);
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  prompter_rs: ^0.0.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:prompter_rs/prompter_rs.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
65
Overall:
Weighted score of the above. [more]
43
Learn more about scoring.

We analyzed this package on Jul 8, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.14

Analysis suggestions

Package not compatible with runtime flutter-web on web

Because:

  • package:prompter_rs/prompter_rs.dart that imports:
  • package:prompter_rs/src/prompter.dart that imports:
  • package:prompter_rs/src/terminal.dart that imports:
  • dart:io

Package not compatible with runtime js

Because:

  • package:prompter_rs/prompter_rs.dart that imports:
  • package:prompter_rs/src/prompter.dart that imports:
  • package:prompter_rs/src/terminal.dart that imports:
  • dart:io

Health issues and suggestions

Document public APIs. (-1 points)

11 out of 11 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Homepage URL is insecure. (-5 points)

Update the homepage field and use a secure (https) URL.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK <3.0.0