prompter_lz 0.1.1

  • Readme
  • Changelog
  • Example
  • Installing
  • 53

Library to create CLI wizards. Provide the multi options questions for user to select. It also provide the binaray question which is let user to input Y or N which means yes or no.

0.1.0 #

  • Initial version, created by Lei

0.1.1 #

  • update description

example/main.dart

import 'package:prompter_lz/prompter_lz.dart';

void main(List<String> args) {
  final prompt = const Prompter();

  final options = [
    new Option('I want red', '#f00'),
    new Option('I want blue', '#00f'),
  ];

  final colorCode = prompt.askMultiple("What's your favorite color?", options);
  final answer = prompt.askBinary("Do you love dart?");
  print(colorCode);
  print(answer);
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  prompter_lz: ^0.1.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:prompter_lz/prompter_lz.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
14
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
80
Overall:
Weighted score of the above. [more]
53
Learn more about scoring.

We analyzed this package on Oct 7, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.1
  • pana: 0.12.21

Platforms

Detected platforms: Flutter, other

Primary library: package:prompter_lz/prompter_lz.dart with components: io.

Health issues and suggestions

Document public APIs. (-1 points)

11 out of 11 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Maintenance issues and suggestions

Homepage URL doesn't exist. (-20 points)

At the time of the analysis the homepage field https://pub.dev/packages/prompter_lz was unreachable.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK <3.0.0