prompter_ic 0.0.1

  • README.md
  • Example
  • Installing
  • Versions
  • 41

Hello, this project it's just for learning.

Thank you.

example/main.dart

import 'package:prompter_ic/prompter_ic.dart';

void main() {
  final prompter = new Prompter();
  
  var options = [
    new Option('Red', '#f00'),
    new Option('Blue', '#00f'),
  ];

  final String colorCode = prompter.askMultiple('Seleccione un color', options);

  final bool res = prompter.askBinary('do you like dart?');
  
  print(colorCode);
  print(res);

}//main

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  prompter_ic: ^0.0.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:prompter_ic/prompter_ic.dart';
  
Version Uploaded Documentation Archive
0.0.1 Dec 27, 2018 Go to the documentation of prompter_ic 0.0.1 Download prompter_ic 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
54
Overall:
Weighted score of the above. [more]
41
Learn more about scoring.

We analyzed this package on Jun 17, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.3.2
  • pana: 0.12.18

Platforms

Detected platforms: Flutter, other

Primary library: package:prompter_ic/prompter_ic.dart with components: io.

Health issues and suggestions

Document public APIs. (-1 points)

11 out of 11 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Format lib/prompter_ic.dart.

Run dartfmt to format lib/prompter_ic.dart.

Format lib/src/option.dart.

Run dartfmt to format lib/src/option.dart.

Format lib/src/prompter.dart.

Run dartfmt to format lib/src/prompter.dart.

Format lib/src/terminal.dart.

Run dartfmt to format lib/src/terminal.dart.

Maintenance issues and suggestions

Provide a file named CHANGELOG.md. (-20 points)

Changelog entries help developers follow the progress of your package. See the example generated by stagehand.

The package description is too short. (-16 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK <3.0.0