prompter_fu 1.0.1

  • Readme
  • Changelog
  • Example
  • Installing
  • 50

Example Project

1.0.0 #

  • Initial version, created by Fuad

1.0.1 #

  • Minor bug fixes


import 'package:prompter_fu/prompter_fu.dart';

void main() {
  final options = <Option>[
    Option(label: 'Red', value: '#F00'),
    Option(label: 'Green', value: '#0F0'),
    Option(label: 'Blue', value: '#00F'),

  final prompter = new Prompter();
  String colorCode = prompter.askMCQ('Choose a color', options);
  bool answer = prompter.askBinary('Do you like dart?');

  print('Your selected color\'s code is ${colorCode}');
  print('You ${answer ? 'do' : 'do not'} like dart');

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  prompter_fu: ^1.0.1

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:prompter_fu/prompter_fu.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Nov 20, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.6.1
  • pana: 0.12.21


Detected platforms: Flutter, other

Primary library: package:prompter_fu/prompter_fu.dart with components: io.

Health issues and suggestions

Document public APIs. (-1 points)

12 out of 12 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Format lib/src/terminal.dart.

Run dartfmt to format lib/src/terminal.dart.


Package Constraint Resolved Available
Direct dependencies
Dart SDK <3.0.0