prompter_bruno 0.0.2

Prompter #

Prompts question to a terminal and sends response values back to the calling program.

Getting Started #

Include the prompter library in your project. To use the prompter you can make an instance of it by calling Prompter(). You can pass multiple choice questions or simple yes-no questions as arguments to the prompter functions and make use of the returned value in your program.

The value returned have the type string for multiple questions and boolean for yes-no questions.

Prerequisites #

Must have Dart version 2.0 or greater since the keyword new is not used in class constructors.

Installing #

dev_dependencies: prompter_bruno: ^3.0.0

Running the tests #

import 'package:prompter_bruno/prompter_bruno.dart';

final List

// No need to use the 'new' keyword with Dart 2.0 or greater final prompter = Prompter();

// Pass a multi-choice question and return String value String colorCode = prompter.askMultiple('Select a color', options);

// Pass a yes-no question and return a boolean value bool answer = prompter.askYesNo('Do you like this lib?');

// Print the values if needed to confirm results print(colorCode); print(answer);

Built With #

Visual Studio Code - version 1.33.1

Authors #

  • Bruno

License #

This project is licensed under the MIT License

Acknowledgments #

  • Prompter is part of a code project given by Stephen Grider.

example/main.dart

import 'package:prompter_bruno/prompter_bruno.dart';

void main() {
  final List<Option> options = [
    Option('I want red', '#f00'),
    Option('I want blue', '#00f'),
    Option('I want yellow', '#ff0'),
  ];

  // No need to use keyword "new" since Dart 2.0
  final prompter = Prompter();

  String colorCode = prompter.askMultiple('Select a color', options);
  bool answer = prompter.askYesNo('Do you like this lib?');

  print(colorCode);
  print(answer);
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  prompter_bruno: ^0.0.2

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:prompter_bruno/prompter_bruno.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
50
Overall:
Weighted score of the above. [more]
40
Learn more about scoring.

We analyzed this package on Oct 7, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.1
  • pana: 0.12.21

Platforms

Detected platforms: Flutter, other

Primary library: package:prompter_bruno/prompter_bruno.dart with components: io.

Health issues and suggestions

Document public APIs. (-1 points)

11 out of 11 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Maintenance issues and suggestions

Provide a file named CHANGELOG.md. (-20 points)

Changelog entries help developers follow the progress of your package. See the example generated by stagehand.

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK <3.0.0