prompter_arp 0.0.2

  • Readme
  • Changelog
  • Example
  • Installing
  • 8

This is just a practice how to make library in dart

pu

example/main.dart

import 'package:prompter_arp/prompter_arp.dart';

main(List<String> args) {
  final options = [
    Option('I want red', '#f00'),
    Option("I want blue", "#00f"),
  ];

  final prompter = Prompter();
  String colorCode = prompter.askMultiple("What color you want?", options);

  bool answer = prompter.askBinary("Do you like this lib?");

  print(colorCode);
  print(answer);
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  prompter_arp: ^0.0.2

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:prompter_arp/prompter_arp.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
16
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
8
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK <4.0.0