prompter_andreasgarvik 0.0.2
prompter_andreasgarvik: ^0.0.2 copied to clipboard

Library to create cli wizard

0
likes
25 / 110
pub points
0 %
popularity

We analyzed this package on Jan 12, 2021, and awarded it 25 pub points (of a possible 110):

Follow Dart file conventions
5 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

0/5 points: Provide a valid CHANGELOG.md

No `CHANGELOG.md` found.

Changelog entries help developers follow the progress of your package. See the example generated by stagehand.

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

0/10 points: Failed to run dartdoc

  • Running dartdoc failed with the following output:

Support multiple platforms
0 / 20

0/20 points: Supports 0 of 2 possible platforms (native, js)

Package resolution failed. Could not determine platforms.

Run pub get for more information.

Pass static analysis
0 / 30

0/30 points: code has no errors, warnings, lints, or formatting issues

ERROR: The parameter 'label' can't have a value of 'null' because of its type, but the implicit default value is 'null'.

lib/src/option.dart:5:16

  ╷
5 │   Option({this.label, this.value});
  │                ^^^^^
  ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/option.dart

ERROR: A value of type 'String?' can't be returned from method 'collectInput' because it has a return type of 'String'.

lib/src/terminal.dart:20:12

   ╷
20 │     return stdin.readLineSync();
   │            ^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/terminal.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

  • Could not run pub outdated: pub get failed:
pubspec.yaml has no lower-bound SDK constraint.
You should edit pubspec.yaml to contain an SDK constraint:

environment:
  sdk: '>=2.10.0 <3.0.0'

See https://dart.dev/go/sdk-constraint

10/10 points: Package supports latest stable Dart and Flutter SDKs