progress_hud 0.2.2

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 47

progress_hud #

A clean and lightweight progress HUD for your Flutter app

https://pub.dartlang.org/packages/progress_hud

Example #

return new Scaffold(
  appBar: new AppBar(
    title: new Text('ProgressHUD Demo'),
  ),
  body: new Stack(
    children: <Widget>[
      new Text(
        'A clean and lightweight progress HUD for your Flutter app'
      ),
      new ProgressHUD(
        backgroundColor: Colors.black12,
        color: Colors.white,
        containerColor: Colors.blue,
        borderRadius: 5.0,
      )
    ],
  )
);

Showcase #

[0.2.2]

  • Now can be passed a text, and this text it will appear below the circular progress indicator

[0.1.2]

  • Code improvements based on dartfmt, pubspec file improvements and added an example project

[0.1.1]

  • Added the possibility to show rounded container behind the circular progress indicator

[0.0.1]

  • Initial release

example/lib/main.dart

import 'package:flutter/material.dart';

import 'package:progress_hud/progress_hud.dart';

void main() => runApp(new MyApp());

class MyApp extends StatelessWidget {
  @override
  Widget build(BuildContext context) {
    return new MaterialApp(
      title: 'Flutter Demo',
      theme: new ThemeData(
        primarySwatch: Colors.blue,
      ),
      home: new MyHomePage(title: 'Flutter Demo'),
    );
  }
}

class MyHomePage extends StatefulWidget {
  MyHomePage({Key key, this.title}) : super(key: key);

  final String title;

  @override
  _MyHomePageState createState() => new _MyHomePageState();
}

class _MyHomePageState extends State<MyHomePage> {
  @override
  Widget build(BuildContext context) {
    return new Scaffold(
        appBar: new AppBar(
          title: new Text('ProgressHUD Demo'),
        ),
        body: new Stack(
          children: <Widget>[
            new Text(
                'A clean and lightweight progress HUD for your Flutter app'),
            new ProgressHUD(
              backgroundColor: Colors.black12,
              color: Colors.white,
              containerColor: Colors.blue,
              borderRadius: 5.0,
              text: 'Loading...',
            )
          ],
        ));
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  progress_hud: ^0.2.2

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:progress_hud/progress_hud.dart';
  
Version Uploaded Documentation Archive
1.1.0 Sep 1, 2018 Go to the documentation of progress_hud 1.1.0 Download progress_hud 1.1.0 archive
1.0.0 May 28, 2018 Go to the documentation of progress_hud 1.0.0 Download progress_hud 1.0.0 archive
0.2.2 Mar 14, 2018 Go to the documentation of progress_hud 0.2.2 Download progress_hud 0.2.2 archive
0.1.2 Mar 12, 2018 Go to the documentation of progress_hud 0.1.2 Download progress_hud 0.1.2 archive
0.1.1 Mar 12, 2018 Go to the documentation of progress_hud 0.1.1 Download progress_hud 0.1.1 archive
0.0.1 Mar 11, 2018 Go to the documentation of progress_hud 0.0.1 Download progress_hud 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
95
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
47
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.23.0 <2.0.0