primitive_wrappers 0.0.1

  • Readme
  • Changelog
  • Example
  • Installing
  • 48

primitive_wrappers #

Wrapper(s) for primitive dart type(s) to pass it by reference.

0.0.1 #

  • Initial release with Bool wrapper.


import 'package:primitive_wrappers/primitive_wrappers.dart';

main() {
  // Create new wrapper with default value
  Bool wrapper = Bool();
  // get bool value
  if (!wrapper.$)
    // set bool value
    wrapper.$ = true;
  // use overloaded equality operator to compare to bool and new Bool with true value
  if (wrapper == true && wrapper == Bool(init: true)) print('Works fine!');

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  primitive_wrappers: ^0.0.1

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:primitive_wrappers/primitive_wrappers.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Nov 8, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.6.0
  • pana: 0.12.21


Detected platforms: Flutter, web, other

No platform restriction found in primary library package:primitive_wrappers/primitive_wrappers.dart.

Health suggestions

Format lib/src/bool_wrapper.dart.

Run dartfmt to format lib/src/bool_wrapper.dart.

Maintenance suggestions

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
Dev dependencies
test any