plurdart 0.1.53 icon indicating copy to clipboard operation
plurdart: ^0.1.53 copied to clipboard

A dart lib for Plurk APIs.

1
likes
20/ 140
pub points
0%
popularity

The package version is not analyzed, because it does not support Dart 3. Until this is resolved, the package will receive a pub score of 0.

icon indicating section status
Follow Dart file conventions
20 / 30icon to trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

icon indicating section status
Provide documentation
0 / 20icon to trigger folding of the section

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: Failed to run dartdoc

  • Failed to resolve dependencies.
stdout: [  +15 ms] executing: [/tool/stable/flutter/] git -c log.showSignature=false log[...]
[  +39 ms] Exit code 0 from: git -c log.showSignature=false log -n 1 --pretty=format:%H
[   +1 ms] 84a1e904f44f9b0e9c4510138010edcc653163f8
[   +1 ms] executing: [/tool/stable/flutter/] git tag --points-at 84a1e904f44f9b[...]
[  +67 ms] Exit code 0 from: git tag --points-at 84a1e904f44f9b0e9c4510138010edcc653163f8
[        ] 3.10.0
[   +6 ms] executing: [/tool/stable/flutter/] git rev-parse --abbrev-ref HEAD
[  +10 ms] Exit code 0 from: git rev-parse --abbrev-ref HEAD
[        ] HEAD
[        ] executing: [/tool/stable/flutter/] git rev-parse --abbrev-ref --symbo[...]
[   +8 ms] Exit code 128 from: git rev-parse --abbrev-ref --symbolic @{upstream}
[        ] fatal: HEAD does not point to a branch
[  +14 ms] Unable to locate an Android SDK.
[   +9 ms] executing: uname -m
[   +6 ms] Exit code 0 from: uname -m
[        ] x86_64
[  +65 ms] Artifact Instance of 'AndroidGenSnapshotArtifacts' is not required, s[...]
[        ] Artifact Instance of 'AndroidInternalBuildArtifacts' is not required,[...]
[        ] Artifact Instance of 'IOSEngineArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'FlutterWebSdk' is not required, skipping update.
[...]
[        ] Artifact Instance of 'IosUsbArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'FontSubsetArtifacts' is not required, skipping update.
[        ] Artifact Instance of 'PubDependencies' is not required, skipping update.
[ +109 ms] executing: [/tmp/pub-dartlang-dartdocZFCIAM/pkg/] /tool/stable/flutte[...]
MSG : Resolving dependencies...
MSG : Logs written to /tmp/tool-envHARWMN/pub-cache-dirTSVJUC/log/pub_log.txt.
[+1281 ms] pub failed
           command: "/tool/stable/flutter/bin/cache/dart-sdk/bin/dart pub --supp[...]
           pub env: {
             "FLUTTER_ROOT": "/tool/stable/flutter",
             "PUB_ENVIRONMENT": "bot.pub_dartlang_org.docker:bot.pkg_pana:flutte[...]
             "PUB_CACHE": "/tmp/tool-envHARWMN/pub-cache-dirTSVJUC",
           }
           exit code: 65

[  +23 ms] "flutter pub" took 1,572ms.
[  +34 ms] Running 0 shutdown hooks
[   +2 ms] Shutdown hooks complete
[   +2 ms] exiting with code 65

stderr: FINE: Pub 3.0.0
FINE: Resolving dependencies finished (0.076s).
ERR : The lower bound of "sdk: '>=2.7.0 <3.0.0'" must be 2.12.0'
    | or higher to enable null safety.
    | 
    | The current Dart SDK (3.0.0) only supports null safety.
    | 
    | For details, see https://dart.dev/null-safety
FINE: Exception type: DataException
FINE: package:pub/src/entrypoint.dart 987:7                Entrypoint._checkSdkConstraint
    | package:pub/src/entrypoint.dart 359:7                Entrypoint.acquireDep[...]
    | package:pub/src/log.dart 438:18                      progress
    | package:pub/src/entrypoint.dart 358:24               Entrypoint.acquireDependencies
    | package:pub/src/command/upgrade.dart 133:13          UpgradeCommand._runUpgrade
    | package:pub/src/command/upgrade.dart 122:13          UpgradeCommand.runProtected
    | package:pub/src/command.dart 199:21                  PubCommand.run.<fn>
    | dart:async                                           new Future.sync
    | package:pub/src/utils.dart 113:12                    captureErrors.wrappedCallback
    | package:stack_trace                                  Chain.capture
    | package:pub/src/utils.dart 126:11                    captureErrors
[...]
           <asynchronous suspension>
           #5      AppContext.run.<anonymous closure> (package:flutter_tools/src[...]
           <asynchronous suspension>
           #6      CommandRunner.runCommand (package:args/command_runner.dart:212:13)
           <asynchronous suspension>
           #7      FlutterCommandRunner.runCommand.<anonymous closure> (package:[...]
           <asynchronous suspension>
           #8      AppContext.run.<anonymous closure> (package:flutter_tools/src[...]
           <asynchronous suspension>
           #9      FlutterCommandRunner.runCommand (package:flutter_tools/src/ru[...]
           <asynchronous suspension>
           #10     run.<anonymous closure>.<anonymous closure> (package:flutter_[...]
           <asynchronous suspension>
           #11     AppContext.run.<anonymous closure> (package:flutter_tools/src[...]
           <asynchronous suspension>
           #12     main (package:flutter_tools/executable.dart:91:3)
           <asynchronous suspension>



icon indicating section status
Platform support
0 / 20icon to trigger folding of the section

0/20 points: Platform support detection failed

Could not determine supported platforms as package resolution failed.

Run flutter pub get for more information.

icon indicating section status
Pass static analysis
0 / 30icon to trigger folding of the section

0/30 points: code has no errors, warnings, lints, or formatting issues

Found 1803 issues. Showing the first 2:

ERROR: Target of URI doesn't exist: 'package:flutter/foundation.dart'.

lib/plurdart.dart:7:8

  ╷
7 │ import 'package:flutter/foundation.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/plurdart.dart

ERROR: Target of URI doesn't exist: 'package:http/http.dart'.

lib/plurdart.dart:9:8

  ╷
9 │ import 'package:http/http.dart' as Http;
  │        ^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/plurdart.dart

icon indicating section status
Support up-to-date dependencies
0 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Sdk constraint doesn't support current Dart version 3.0.0. Cannot run `flutter pub outdated`.

pubspec.yaml:7:8

  ╷
7 │   sdk: ">=2.7.0 <3.0.0"
  │        ^^^^^^^^^^^^^^^^
  ╵

0/10 points: Package supports latest stable Dart and Flutter SDKs

Sdk constraint doesn't support current Dart version 3.0.0.

pubspec.yaml:7:8

  ╷
7 │   sdk: ">=2.7.0 <3.0.0"
  │        ^^^^^^^^^^^^^^^^
  ╵

Try widening the upper boundary of the constraint.

The current SDK constraint does not allow the Dart version used by the latest stable Flutter (3.0.0)

pubspec.yaml:7:8

  ╷
7 │   sdk: ">=2.7.0 <3.0.0"
  │        ^^^^^^^^^^^^^^^^
  ╵
icon indicating section status
Dart 3 & Flutter 3.10 compatibility
0 / 20icon to trigger folding of the section

0/20 points: Unable to detect Dart 3 & Flutter 3.10 compatibility

  • Failed to analyze Dart 3 & Flutter 3.10 compatibilty:
Unable to run pub upgrade.
The lower bound of "sdk: '>=2.7.0 <3.0.0'" must be 2.12.0'
or higher to enable null safety.

The current Dart SDK (3.1.0-63.0.dev) only supports null safety.

For details, see https://dart.dev/null-safety

Analysed with Pana 0.21.32, Flutter 3.10.0, Dart 3.0.0.