pikachu_fac 1.0.3

Flutter architecture components

2
likes
55 / 110
pub points
21 %
popularity

We analyzed this package on Oct 27, 2020, and awarded it 55 pub points (of a possible 110):

Follow Dart file conventions
5 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 1 image link is insecure.

README.md:79:4

   ╷
79 │ <p><img src="http://storage.lianjia.com/infra-weapons/1595823478406.png?AWSAccessKeyId=BF78D858573CFD2BE99D&Expires=1596547384&Signature=mx47nT4Y0AUuurQy59yyACu0FbE%3D" alt="image.png" /></p>
   │    ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

Use https URLs instead.

`README.md` contains too many non-ASCII characters.

The site uses English as its primary language. The content of README.md in your package should primarily contain characters used in English.

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 8 out of 32 API elements (25.0 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
0 / 30

0/30 points: code has no errors, warnings, lints, or formatting issues

Found 3 issues. Showing the first 2:

ERROR: This requires the 'spread-collections' language feature to be enabled.

lib/src/live_state.dart:98:20

   ╷
98 │       _lastMemo = [..._memo(_ctrl._state)];
   │                    ^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/live_state.dart

ERROR: This requires the 'spread-collections' language feature to be enabled.

lib/src/live_state.dart:111:25

    ╷
111 │         List nowMemo = [..._memo(_ctrl._state)];
    │                         ^^^
    ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/live_state.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
provider^3.2.03.2.04.3.2+2
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.0-nullsafety.31.1.0-nullsafety.4
collection-1.15.0-nullsafety.31.15.0-nullsafety.4
meta-1.3.0-nullsafety.31.3.0-nullsafety.5
sky_engine-0.0.990.0.99
typed_data-1.3.0-nullsafety.31.3.0-nullsafety.4
vector_math-2.1.0-nullsafety.32.1.0-nullsafety.4

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^3.2.0` on provider does not support the latest published version `4.3.2+2`

pubspec.yaml:12:13

   ╷
12 │   provider: ^3.2.0
   │             ^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

2
likes
55
pub points
21%
popularity

Publisher

gavinme.com

Flutter architecture components

Repository (GitHub)
View/report issues

Documentation

API reference

License

unknown (LICENSE)

Dependencies

flutter, provider

More

Packages that depend on pikachu_fac